FreedomPop 101: FreedomPop Diagnostics Application — FreedomPop Community

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Hi there!

Big news — we’ve got a new Community design coming for you on 4/25/2017. We can’t wait for you to check it out!

A few important notes:

Any posts you create on the current Community after 4/25 12:00 PM PST. might not carry over in the migration. We recommend holding off on posting after that point (until the new Community is live).
Your username and password are staying the same, and all your posts and comments will carry over too. No need to worry about missing content!

Thanks so much for your support and patience through the migration process. Let us know if you have any questions or concerns!

- The FreedomPop Community Team

FreedomPop 101: FreedomPop Diagnostics Application

Karina Karina Posts: 2,096 admin



The FreedomPop Diagnostic App was designed to be a companion when resolving any issues with our tech support during call or via email. Not only does this app allow you to test sounds/calls, display, battery and network but you can also take other actions!

Note: This app is only compatible with android devices (4.0.3 and up).

Current Version
1.02.97.1110







Key Features:
Easy to navigate menu
Status reporting
One click access to all system menus and settings
Instant access to unique phone identification information
Check current connection status and type
Test for the audio output and input with clarity readings
You can download our app.



WHAT'S NEW

Version 1.02.97.1110
-Added APN Setting Tutorial
- Minor Bug Fix
Version 1.02.85.0811
- Newer UI/UX
- Spanish language localization
- Performance improvement
- Minor bug fixes
Version 1.02.72.0503
- dual sim device information reporting
- Interactive volume adjustment during audio testing
- updated app installation reporting
- Minor bug fixes for lollipop devices


Comments

  • IngeniousIdeaIngeniousIdea FreedomPop Newbie Posts: 1
    This app is really cool and useful, but unfortunately it didn't fix my network data problem.

    It says my device is incompatible for a soft or hard reset. I've tried all the other options I've found on the forums, but still the number only works when I'm connected to wifi.

    I sent out a ticket about a week ago...

    Question Reference # 170212-000716
    Date Created: 02/12/2017 03:42 PM
    Date Last Updated: 02/12/2017 03:42 PM
    Status: Unresolved

    I just wonder if anyone else can help. Thank you!
  • Jona SkiJona Ski FreedomPop Newbie Posts: 134
    Would this help with BYOD CDMA problems? I really think my sim wasn't registered at activated but no rep with refresh my account to see if that's what is the problem. They keep saying it's because the messaging app is not installed, but I don't see how that's necessary for a cellular data cellular. Doesn't matter anyway because that's not the problem because I've had it installed and still no internet connection, no 3G/4G symbols just those bars show.
    I like me deals and free stuff. Thx, peeps
  • pkp413pkp413 FreedomPop Newbie Posts: 3
    I have installed the latest version of diagnostic app, but every time I start it it says "Unfortunately, FreedomPop Diagnostic has stopped."
  • Vincent SteadmanVincent Steadman FreedomPop Newbie Posts: 7
    edited March 8 #5
    Tried the diagnostic app before but its very basic in terms of suggesting that everything is / will work OK. It does no real call / connection testing.

    I suggest you (Freedompop) take a look at the following app and see if you can integrate similar functionality in some way: https://play.google.com/store/apps/details?id=com.antisip.firewallvoipchecker

    It does actually perform a connection test to determine your chances of things working a lot better. E.g. when I use it at a location where the Freedompop Wifi calling doesn't work it tells me that the NAT (or firewall in this case) system is completely blocked and it can't get to the server. At locations where it does work it states the NAT type and success at testing a connection.

    And that is just a basic tool, which doesn't even try the voice / RTSP part of the process. Long story short, the diagnostics could be much more deeper.
    Post edited by Vincent Steadman on
  • Tally FellsTally Fells FreedomPop Newbie Posts: 14
    edited March 21 #6
    As pkp413 says... every time I try to use it to help fix my problem it fails and says
    "Unfortunately, FreedomPop Diagnostic has stopped."

    Completely useless.

    BTW... I can make calls on my new Kyocera Hydro Icon phone (purchased directly from Freedompop) but can not RECEIVE ANY phone calls. They go to voice mail and the phone never rings. (Note... on WiFi... have not had a chance to check while on LTE)

    **** UPDATE: I have gone out to the main highway where I have 3G as well as further down where I have LTE.... I can receive calls just fine there! So phone is working (yay), but not receiving on WiFi....
    So I can get incoming calls while on LTE or 3G but NOT while on WiFi alone.
    I CAN make outgoing calls on WiFi, but not get INCOMING calls on WiFi.
    Hubby thinks it is probably something wrong with the way it is routing WiFi calls, but I have tried everything and nothing works to fix it.
    Post edited by Tally Fells on
  • Thinker76erThinker76er FreedomPop Newbie Posts: 12
    display a message as Tally Fells
    "Unfortunately, FreedomPop Diagnostic has stopped."
  • Rich Sias (16th)Rich Sias (16th) FreedomPop Newbie, FreedomPop Master, FreedomPop Pro Posts: 2,468 ✭✭✭✭✭
    @Tally Fells @Thinker76er
    I found this item that may help.
    Concerning no incoming calls when on WiFi.

    "I had the same problem. I discovered on my WiFi router under Advanced -> Firewall Settings -> APPLICATION LEVEL GATEWAY (ALG) CONFIGURATION that SIP was unchecked. Checking it and then clicking Save Settings fixed the problem for me!"
    Be my Valentine ZTE, Victory, LG Volt, & 803S
  • gezageza FreedomPop Newbie Posts: 8
    Trying to use this app. Crashes on startup with "Unfortunately, FreedomPop Diagnostic has stopped." Samsung Galaxy S3 on Android 4.4.2
  • Tally FellsTally Fells FreedomPop Newbie Posts: 14

    @Tally Fells @Thinker76er
    I found this item that may help.
    Concerning no incoming calls when on WiFi.

    "I had the same problem. I discovered on my WiFi router under Advanced -> Firewall Settings -> APPLICATION LEVEL GATEWAY (ALG) CONFIGURATION that SIP was unchecked. Checking it and then clicking Save Settings fixed the problem for me!"

    Not sure completely how to do this, but I really don't think that could be the issue... I can make calls out on the wifi, and I borrowed my sister's freedompop phone and it receives calls just fine on the same wifi network.

    So if one phone works on the wifi network just fine, and I can call out on the trouble phone, it should not be the network, right?
Sign In or Register to comment.