How to update app if you have sideloaded it

salvadorfreemansonsalvadorfreemanson Posts: 64FreedomPop Newbie ✭✭✭
I had to sideload the FP app (Google Play store doesn't like me!) and it works fine. Thanks to the person who posted it on the forum.
But now I would like to install the updated version that was released a week ago.
Since I didn't get it from the Google Play store, there appears to be no way to update it automatically.
So how do I update it ?

Comments

  • Marc JosephMarc Joseph Posts: 172FreedomPop Newbie
  • salvadorfreemansonsalvadorfreemanson Posts: 64FreedomPop Newbie ✭✭✭
    I get the following message
    " This app is incompatible with all of your devices."

    This is in fact clearly untrue, as it's currently running happily on my Ice-phone. But the devices listed as incompatible include my wife's Moto G, as well as a high range Huawei that I had on loan.
    As I said, Google Play doesn't like me. Probably because I set up the account when I lived in France, although that was some time ago and I'm in the UK now and the phones have both UK and French SIMs But in that case, shouldn't it say "not available in your country"? In any case, it's not a purely geolocation thing, as in that case I wouldn't be able to install BBC iplayer and suchlike, which I can (but friends in France can't).
    Whatever the reason, Google just doesn't let me install the FP app.
    And looking around on the US forum, some people over there have issues with Google Player too and so FP have posted the US app, although I can't find the link right now.
  • Robert ZimmermanRobert Zimmerman Posts: 95FreedomPop Newbie
    You need to sideload the updated version if you sideload the app initially, unless you can find an app that will automate downloading the APK from the Play Store and installing it.
  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    edited October 2015 #5
    @salvadorfreemanson
    what version of Android are you using on those devices? I know right now we are having issues getting a updates or simply re-downloading the Freedompop Messaging app on Android versions under 4. HTC Evo 4g's use Android 2.3 and it was first reported with those phones.

    I am sure on Monday once the admins make there round they will create a ticket for you? I asked what we needed to do if another member needed the app using that version of android. One of the Admins Replied, it would be giving threw customer support.

    Edit, Make sure to dbl check your version before you install from a different site other than Freedompop.

    The highest version Freedompop App on Android 2.3 is version 16.02.276.0617
    Post edited by njfulwider5 on

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

  • salvadorfreemansonsalvadorfreemanson Posts: 64FreedomPop Newbie ✭✭✭
    Thanks pacoman.
    I think the problem is with Google rather than with Freedompop. Google have their way of deciding who has a right to install which app, and then lying saying that the app is not compatible with a device.
    So it looks as though I'll have to depend on people uploading the apk file, or extract a file from someone else's phone.

    Maybe the solution will be for me to set up a new google account and wipe my phone. But that's a long way round, and I don't think I should have to do that.

    @njfulwider I have about a dozen phones listed on my google account, as I get phones on test for a couple of weeks. All of them are listed as incompatible on the Google play store. Most of them are various flavours of Android 4. I do also have a spare android 2.3 phone, but I didn't even think of trying it. Where can I find the relevant apk file (since google won't let me download it)?
  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    @salvadorfreemanson
    Just looked at @pacoman and it looks might work for you. The only other option is to contact customer service.

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

  • Robert ZimmermanRobert Zimmerman Posts: 95FreedomPop Newbie
    As an alternative to figuring out how to get the Play Store running, you can always try 1Mobile Market. They're not the most well known, and the apps aren't updated instantaneously (FP Messaging was updated a day after it was on the Play Store) or as numerous, but they do offer auto-updates.

    Alternatively, you could also just use a service like Evozi's APK Downloader to pull the latest FP Messaging updates when they're released.
  • salvadorfreemansonsalvadorfreemanson Posts: 64FreedomPop Newbie ✭✭✭
    It worked! App updated.

    While I was at it, I thought I'd try it on a tablet. I get a message saying please uninstall this app, with a link to an app on the google market. This then says that the app is not availble in my country (I'm in London).
Sign In or Register to comment.