How to select FP or other SIM for outgoing call

SolomonSolomon Posts: 207FreedomPop Newbie
I've just noticed that the FP messaging app takes priority for outgoing calls - they are all routed via FP. The only way I found to overcome this was to go into settings/apps and force the FP app to stop.

Is there a simpler way to do this?

Comments

  • cagstercagster Posts: 168FreedomPop Newbie ✭✭✭
    Do you have android phone ? Are you connect to data/wifi at that time ? Were you trying to use premium voice ? If so turn off wifi and data and try again. If still an issue you should be able to disable default applications in settings associated to the phone dialler and retry. For me rebooting the phone seems to remove defaults.
  • SolomonSolomon Posts: 207FreedomPop Newbie
    It's an Android phone and it was connected to wifi. In fact the FP sim wasn't even inserted. I'm outside the UK at the moment and I had just made a couple of calls to UK mobiles using FP and wifi. Then I wanted to make a local call using my local SIM, but the call was placed via FP. Curiously, I got a message saying that I didn't have any international minutes, even though I had only used the number without the international dialing codes. Perhaps that was because it was in my address book.
    I'll try again this evening, using your suggestion of turning off the wifi.
  • cagstercagster Posts: 168FreedomPop Newbie ✭✭✭
    But the local sim in and reboot the phone too if you haven't already
  • SolomonSolomon Posts: 207FreedomPop Newbie
    It works!
    Basically, you switch between the local SIM and Freedompop by turning the wifi on and off. Of course the data is off, because the allowance on the local sim is 50 MB a month. At the moment I'm using a dual SIM phone, with the local SIM in slot one and none in slot 2. When I go back to the UK next week, I suppose the best config will be FP in slot one and the French sim in slot 2.
  • Alex WalesAlex Wales Posts: 68FreedomPop Newbie
    I concur with Solomon. FP is prioritised for outgoing calls once the app is active, and the only way I've found to stop this is to disable the app, just as suggested. I have a dual SIM phone currently without the FP sim in either slot, but the FP dialer takes over after the FP app is run. It has nothing to do with WiFi status. Rebooting the phone is a bit pointless, either the FP app doesn't run on startup in which case the default dialer will work up until the FP app is opened, or if it does run on startup then you're no better off.
  • Alex WalesAlex Wales Posts: 68FreedomPop Newbie
    Ok, I'll have to do some more investigation...
  • cagstercagster Posts: 168FreedomPop Newbie ✭✭✭
    My default dialler always works irrespective of whether I have used the FP app - i use the default dialler for call and FP app for text
  • SolomonSolomon Posts: 207FreedomPop Newbie
    I go back on my posting the other day. On Friday night, switching off the wifi worked. Today, it didn't! I I made a call on FP last niight via wifi. Then this morning I sent a text message with the French SIM. Then I wanted to call a French number, with the French SIM. I was out of range of wifi, but the FP app kicked in. So, I turned the wifi off anyway. The phone still tried to use the FP app. In the end I had to go into settings (Android phone) and manually stop the FP app.
  • cdma62xcdma62x Posts: 17FreedomPop Newbie
    It is very confusing. I installed FP at sim slot one, every time I tried to use native dialer to call my voice mail from sim 2, fp software jumps out to make the call. It needs to get improved please!
  • #123##123# Posts: 2FreedomPop Newbie
    I’ve detected the same issue; once the app is installed it always uses freedom pop for calls (i.e. mod’s native dialler). It seems that this is not possible without killing the app…
  • DB13DB13 Posts: 1FreedomPop Newbie
    Unfortunately I've had the same problem with my 2nd gen Moto G in that the FP app overrides all the dual sim settings and even with Wifi turned off I am unable to use the second sim as a message saying "Network not available" comes up. If I do select the second sim to make a call through, it still routes via the FP sim. Therefore in order to use the dual sim facility (which is the reason for having purchased that handset) I've found that I have to uninstall the FP app each time.

    Possibly FP could look into doing something with the app so that it doesn't override the dual sim settings on the phone and will allow the user to choose which sim is used?
  • ShyuanShyuan Posts: 10FreedomPop Newbie
    Hi,

    Is this issue being looked into? My friend is using OnePlus X which is also a dual SIM, now she needs to call using giffgaff SIM but FP keeps taking over it.
  • dooetdooet Posts: 1FreedomPop Newbie
    if you disable "phone" from "App permissions" then FreedomPop will still accept incoming calls, but not make outgoing calls (even through the Messaging app). Grant the permission again and you are outgoing calls will be made through FreedomPop
Sign In or Register to comment.