NO SIM CARD DETECTED. (Global SIM)

cdma62xcdma62x FreedomPop Newbie Posts: 17
Dear support team,

I received my novatel MIFI2 device along with SIM card loaded several days ago. Today I finally decide to open it and have a test. However, after I put the battery inside and start the device, error message says "No SIM card detected. Please insert a SIM." I also tried to pull it out and reinsert for a few times. Still the problem remains the same. What can I do??

Comments

  • Anne HurleyAnne Hurley FreedomPop Newbie Posts: 34
    I don't want this sound daft hi , but is the simcard activated?
  • cdma62xcdma62x FreedomPop Newbie Posts: 17
    annie said:

    I don't want this sound daft hi , but is the simcard activated?

    According to FP policies, global SIM card are sent with activiated status. I pulled it in my phone yesterday, there was singal with 3 network. It seems that this device can't detect the SIM card. What should I do? Can I return this in this case?

  • Jorge Jorge Posts: 3,375 admin
    @cdma62x I took a look into your account and all does look to be in good standing, if you can please confirm the ICCID number on your end we will be glad to take a closer look into this for you :)
  • cdma62xcdma62x FreedomPop Newbie Posts: 17
    Jorge M. said:

    @cdma62x I took a look into your account and all does look to be in good standing, if you can please confirm the ICCID number on your end we will be glad to take a closer look into this for you :)

    Dear Jorge,
    My global SIM card is associated with my another account. And based on what I observed, it is more likely that the MIFI device can't detect my SIM card. It works fine with my cell phone. Anyway, the ICCID no. for the SIM card is 8944200012 789893868.

    I also find out that I can't upgrade or downgrade my global SIM plan. Could you also check it for me please?

    Many thanks.
  • cdma62xcdma62x FreedomPop Newbie Posts: 17
    Could anyone from the customer service team look into my issue? It has been 10 days, problem still remains the same.. :s
  • james bloomjames bloom FreedomPop Newbie Posts: 5
    Dear Jorge I have all the same troubles as cdma62x this seems a common problem with the mifi2. It arrived without any paper work invoice etc so how do i return for refund.Sim card numbers:-8944200012/78983827.
    Thanks
  • David ChengDavid Cheng FreedomPop Newbie Posts: 4
    I received my Mifi2 today, and, because of this thread, I immediately tested it. It worked fine after several reboots and moving it to an unlocked iPhone. After a couple reboots, though, I did get the "No SIM" message on the Mifi2. It seems to be intermittent. Should I be worried?
  • lindelinde FreedomPop Newbie Posts: 6
    Please update this post and let folks know if the error went away, became permanent, or is still intermittent. The MiFi2 that I ordered in May began generating this error after less than 1 hour of testing it and the error would never go away. By using 2 devices (hotspot and unlocked phone) and 2 SIMs (FP SIM and AT&T SIM), I determined it was definitely the MiFi2 with the problem. It was quite an ordeal to get the device exchanged, but I eventually received a working device in July. However, during the long wait time, someone at FP messed up my account and linked it to a different device, so I can't manage my Global hotspot. I've been trying to get this resolved for weeks, so far unsuccessfully.
  • lindelinde FreedomPop Newbie Posts: 6
    About a week after my earlier post, someone finally got my account restored back to a hotspot account and I was able to see my correct data, etc. I ended up bringing this Global Hotspot to Amsterdam and 4 cities/towns in Norway in late July & early August and it worked in all 5 places! It wasn't perfect and sometimes it got a signal in a place you wouldn't expect but not in a more populated area where you would expect it to work. In any case, I was able to use it enough to be well worth the purchase (but not necessarily the 2+ month ordeal of replacing a defective hotspot and then having the account messed up). In September I was a passenger for a 21 hour car trip from AL to NY. I had a signal the entire way! For a short time in the mountains, it dropped to GSM, but mostly 3-4 bars of H+. I'm now very happy with this purchase and I hope it doesn't flake out like the first one did. During all its use in the last 6 weeks, the device shut down at least 2 times for no reason. I restarted it and it was fine. I have kept it on for 5-6 hours at a time and never completely ran down the battery.
  • Damon FongDamon Fong FreedomPop Newbie Posts: 5
    i'm having the same problem. Mifi sometimes cannot detect sim card. Works once in a while only
  • govindk22govindk22 FreedomPop Newbie Posts: 6
    I am also having the same issue and support said they can't help after 90 days. any other ways to fix?
  • alaskaalaska FreedomPop Newbie Posts: 7
    I used my device intermittently for about 4 months without issue. Now I am getting the "no SIM card detected" error message. I tried the same SIM in my unlocked phone and it works just fine. Is there any troubleshooting for this? Thanks.
  • EBOEBO FreedomPop Newbie Posts: 1
    I got the same message and found that the SIM card wasn't going in far enough. I used a clamp to keep the SIM card in and it's been working fine ever since.
  • AlejandraGAlejandraG FreedomPop Newbie Posts: 4,763 admin
    EBO said:

    I got the same message and found that the SIM card wasn't going in far enough. I used a clamp to keep the SIM card in and it's been working fine ever since.

    Can you please confirm the ICCID number of your sim?
Sign In or Register to comment.