Downgrading service, final step page fails to load

DaveakaDaveaka Posts: 2FreedomPop Newbie
Hi,
I've just been charged £3.99 for a service that I though I'd cancelled. Turns out I'd only downgraded my plan and freedompop "premier" was still active. I've tried following the steps to deactivate freedompop premier, but the final step fails to load (chrome & explorer). Can the Admin please cancel this service or confirm that it has been deactivated?

I've never made any calls or texts using this service and it's a bit disappointing that I'm being charged for a service that I deactivated within days of receiving the sim (got new contract sim instead)

I've cancelled the paypal preapproved billing

Comments

  • DaveakaDaveaka Posts: 2FreedomPop Newbie
    Just tried again and it seems the problem has been fixed.
  • Jonathan J.Jonathan J. Posts: 465 admin
    Hello,

    I'm glad to know everything is now functioning properly. However, should you encounter any further issues, please feel free to Private Message (P.M.) me and I will gladly assist you further.

    Have a wonderful day! :)

    -Jonathan J.
Sign In or Register to comment.