Account login blocked, shipping 'in progress'

questerquester Posts: 5FreedomPop Newbie
Ordered 2 SIMs on 15th October, as usual I have been signed up for free trials. I was able to login to my account on that date and see the usual stuff I expected to see, like plans, friends etc.

SIMs both arrived Wed/Thurs last week as I expected. I am an existing FP user so know I have to clear cache and data in the FP Messenger app (UK). On Saturday, inserted a SIM in phone. App asked me to activate the SIM (never had to do that before). So I followed the link and entered login credentials OK, but can't get past a banner with 4 green ticks saying shipping in progress but "device has been handed over to the carrier". Well, it has clearly arrived with me now!

Tried login to uk.freedompop.com via a desktop browser and same result.
Can't use SIMs yet, FP app just spins around (waiting for activation?) and no data is being sent.

Can a customer services person please fix my account to show shipment has been received so I can set up my account?

And can the free trial date be reset to the date from which I can actually use the SIMs?

Thanks

Comments

  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • questerquester Posts: 5FreedomPop Newbie
    I have the correct up to date UK app.
    Phone works with an older freedompop sim, so nothing wrong with my phone's APN settings.

    Are you authorised to fix my account to show SIMs have been received so I can at least login using a browser and manage my account?


  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • questerquester Posts: 5FreedomPop Newbie
    Login is not a problem. The login is authenticated but the account is stuck on the shipping status page.

    Screenshots (hope this works):



  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • questerquester Posts: 5FreedomPop Newbie
    edited October 2017 #7
    AlejandraG
    Thanks for the generic advice which was not applicable in this case. As stated above the problem was with shipping status on each SIM of my freedompop account and not my device configuration.

    This problem is now fixed.

    I had to open a support ticket and a Customer Support rep reset the shipping status on my account for each SIM to indicate they had been delivered. This removed the Order Status page (and the yellow lorry symbol) shown above which was blocking access to my account.
    I am now able to login to my account and see the normal menu and manage my account as normal as you can see:




    For anyone else with this issue, please note that the shipping status for each sim has to be separately reset and that you will need to give all your ICCID numbers, so don't dispose of your sim carriers!
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
This discussion has been closed.