Can't create account - error 400 Sms Verification Failed

rm2018rm2018 Posts: 11FreedomPop Newbie
Hi, I wonder if anyone can help me. I've downloaded the FreedomPop app and am trying to create an account using the "Get a 2nd number for your iPhone" button:



I'm in the UK and enter my mobile number when asked, and I get a verification code over SMS. However, when I put the verification code into the FreedomPop app, I get an error message:

FreedomPop Message
400
Sms Verification Failed



I have tried this 12 times now and they have all failed. Can anyone tell me what I need to do to get the verification to work? I can't raise a support ticket as it requires an account, and I can't setup an account because of this error!

Comments

  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • rm2018rm2018 Posts: 11FreedomPop Newbie
    Hi, thanks for helping! I don't have a FreedomPop SIM. I previously used one in the phone a couple of years ago (with a different email address), but now have a giffgaff SIM. I'm trying to set up the '2nd number' feature of the FreedomPop app.
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • rm2018rm2018 Posts: 11FreedomPop Newbie
    Yes, I got this error while on WiFi. The app doesn't offer any other verification method. After entering my name, email address, and password, the next screen asks for a phone number:



    After tapping "Next", it sends me an SMS verification code and asks me to enter it:



    I enter the code, tap "Next", and that's when I get the error.

    There doesn't seem to be any way around it or any other verification method.

    I did also try when not on WiFi using mobile data, but the result was the same (error as in my first post).
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • rm2018rm2018 Posts: 11FreedomPop Newbie
    I created a new Gmail address and tried using that, but I still got the same error 400. :(
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • rm2018rm2018 Posts: 11FreedomPop Newbie
    Yes, this was all done using WiFi.
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • rm2018rm2018 Posts: 11FreedomPop Newbie
    Hi, I've tried it on data and have the same error message. Do you know what this error message means?
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
Sign In or Register to comment.