“I’m sorry. This service is currently unavailable.” Why can’t I often make calls?

RobbieCloseRobbieClose Posts: 2FreedomPop Newbie
It seems random, but really **** me over sometimes. Can anyone solve this? If I use my Phone app to make calls, this error message plays and the call disconnects. If I use the Freedom Pop app to make calls, nobody can hear me - the connection quality is terrible. What’s going on? Data and texts are fine. Only calling is the problem.

Answers

  • Haradhan BhowmikHaradhan Bhowmik Posts: 12FreedomPop Newbie
    I can't make any out going Call. After dialing a number it says "our service is not available now. Please try after some time." Please advise what to do.
  • jamie batchelorjamie batchelor Posts: 32FreedomPop Newbie
    Hello there,

    I am posting about my calling side to my plan isnt working? It states "sorry this service is currently not availible, please try again later", when it's been doing it for the last 3 days?
    Co founder of Reperio Studios
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • adamzioloadamziolo Posts: 1FreedomPop Newbie
    Hi,
    I can’t call at all! I hear message: service currently unavailable. It’s so annoying! I need to change operator.
  • SystemSystem Posts: 16 mod
    This discussion was created from comments split from: Service suddenly unavailable.
  • misterishymisterishy Posts: 0FreedomPop Newbie
    Presented with error message,"we're sorry our service is currently unavailable!"
    iPhone 5 iOS 10.3.3
    I have reset network settings.
    I have reset apn
    I have removed and reinstalled latest version of app
    I don't have another device to test the SIM card in
    Any suggestions?

  • cagstercagster Posts: 169FreedomPop Newbie ✭✭✭
    edited March 25 #8
    I have been getting this for the last few weeks too and just come to this forum to see if anyone else has the problem - so good to know its not just me - was thinking i may need to cancel :-(
  • Francesco_CabidduFrancesco_Cabiddu Posts: 10FreedomPop Newbie
    Hi,
    I can't make calls anymore (Only when using the wi-fi)
    If I try to disconnect the wi-fi there is a voice saying "we are sorry, our service is currently unavailable" when calling.

    Last week I couldn't access the app...all these problems are very frustrating. Please give me some advice thanks.

    I am in the UK and my ICCID is 8944200104412049933

    Thanks
  • Mattie MarkerMattie Marker Posts: 158FreedomPop Newbie, UK Pro ✭✭✭
    This has been plaguing me a few days but well 2 weeks, only found out this happened to me when cycling on a road calling someone to pay them for something. Still happened this morning to call another chap but:
    • App has been updated
    • Account data synced
    • Data roaming on
    • APN is three.co.uk
    • installed the FP diagnostic app and says Messaging needs updating
    Now when i call a number, it uses the FP app on wifi, 3G ends up the same error message.
  • jubayer_jmjubayer_jm Posts: 0FreedomPop Newbie
    I got a sim card but i cant out going call from sim card.when i call they say;we r sorry our servicE is currently unavailable pls call again later.
    But i call app is ok.i also fixed the call settings and premium call but its not working.i also refreshing but still same problem.
    I use internet via sim and incoming call is okay just outgoing call from sim is Problem.
    Pls solution let me thanks
  • zmicerzmicer Posts: 17FreedomPop Newbie
    AlejandraG Could you please update us on what's going on? Quite a few users (including me) are unable to place Premium voice calls - which were part of the deal when FreedomPop switched uses to Essential Plan. If FreedomPop is not willing to honor the initial agreement I'd rather the company was upfront about it so we could switch to a more reliable service instead of waiting in hope.
  • KeiraKeira Posts: 49FreedomPop Newbie
    I am also having this problem since my last payment.

    I've done everything suggested and still cannot make a call unless I am connected to WIFI.

    Not impressed.

    Why is this ?
  • Stephen LandStephen Land Posts: 54FreedomPop Newbie
    Same here.
  • KeiraKeira Posts: 49FreedomPop Newbie
    Hi.
    I have not been able to make a call unless I am on Wifi and restart the network connection, even then sometimes it doesn't work.

    I've not been able to ring doctors, clients, all sorts, and it has worked very little at all, so i'd liek a refund for my last month pls.

    Thank you
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • Haradhan BhowmikHaradhan Bhowmik Posts: 12FreedomPop Newbie
    Hi, I have unlimited calls contract in UK but for lat few days for some reason it says that I can't make calls despite because Freedompop service is not available. However I made few calls to India and Bangladesh and also received incoming calls. My balance and other details are correct. It seems very strange. I need help to sort it out. Can anyone help me please. it will be much appreciated. Thank you.
  • ImnImn Posts: 1FreedomPop Newbie
    "We are sorry. Our service is currently unavailable. Please try again later." But it has been more that 2 weeks that I can't make any outgoing call! And when I installed and tried the FreedomPop messaging app, I couldn't receive nor send any text. I am still being charged for my monthly contract though. FreedomPop can you please resolve this now?
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
  • Mattie MarkerMattie Marker Posts: 158FreedomPop Newbie, UK Pro ✭✭✭


    Good day! We are sorry to learn you are also having issues with placing calls. We are afraid this is currently a known issue with our UK upstream provider and we are working closely with them to fix the issue in a timely manner so you can call from your device's native app.

    Seems to be fixed as of 01/04/2019. I was making phone calls outside a bank but did have to disable Telephone permissions to make sure it made the call
  • cagstercagster Posts: 169FreedomPop Newbie ✭✭✭
    Agree - working (at last) for me too
Sign In or Register to comment.