Can't get FreedomPop app on Android 4.1.2

Will_Pec2Will_Pec2 Posts: 4FreedomPop Newbie
I've been using the service for a long time using my Android 4.1.2 phone. The phone became very cranky and I couldn't fix it so I decided to reset it to factory settings. That fixed the crankiness but I can't now install the FreedomPop app because Google Play says that it is incompatible with my Android version. I assume that the app has been updated to the point that it won't work with my OS. Can I get hold of an older version that will work? I am happy installing APK files.

Bill.

Answers

  • AngiePAngieP Posts: 520FreedomPop Newbie admin
    Will_Pec2 said:

    I've been using the service for a long time using my Android 4.1.2 phone. The phone became very cranky and I couldn't fix it so I decided to reset it to factory settings. That fixed the crankiness but I can't now install the FreedomPop app because Google Play says that it is incompatible with my Android version. I assume that the app has been updated to the point that it won't work with my OS. Can I get hold of an older version that will work? I am happy installing APK files.

    Bill.

    Hello Bill!

    Thanks for reaching out. We apologize for the delay in getting back to you. It is our understanding you're looking to download a previous version of the Messaging app as the latest version is no longer compatible with the Android version you're running on your device. The latest version of the Messaging app is compatible with Android 4.3 or higher. To ensure service works properly, the app must be updated. We do not recommend installing previous versions of the app unless it is recommended by our support team. Unfortunately, it won't be possible for us to provide you with the APK of a previous version. Our suggestion would be that you try your SIM card on a GSM unlocked smartphone, running on Android 4.3 or + / iOS 8.2 or +.
  • Will_Pec2Will_Pec2 Posts: 4FreedomPop Newbie
    Thanks. I have since found a repository of old versions in APK format and installed the last one that works with 4.1.2. My phone is now working nicely again.

    I think this is a shortcoming with Google Play in that it only offers the latest version; if the developer has decided that the current version doesn't work with an older version of the OS, that's just tough.

    Bill.
  • Will_Pec2Will_Pec2 Posts: 4FreedomPop Newbie
    Thanks. I have since found a repository of old versions in APK format and installed the last one that works with 4.1.2. My phone is now working nicely again.

    I think this is a shortcoming with Google Play in that it only offers the latest version; if the developer has decided that the current version doesn't work with an older version of the OS, that's just tough.

    Bill.
  • AngiePAngieP Posts: 520FreedomPop Newbie admin
    Will_Pec2 said:

    Thanks. I have since found a repository of old versions in APK format and installed the last one that works with 4.1.2. My phone is now working nicely again.

    I think this is a shortcoming with Google Play in that it only offers the latest version; if the developer has decided that the current version doesn't work with an older version of the OS, that's just tough.

    Bill.

    Hello Bill, as confirmed before, this is not something we recommend our customers to do unless it is indicated directly by our support team. Please keep in mind that to ensure service works correctly, the best is to have a compatible device (GSM unlocked smartphone, running on Android 4.3 or + / iOS 8.2 or +) and the latest version of the app installed.

    Let us know if there's anything else you may need assistance with, we'll be happy to help.
Sign In or Register to comment.