What Tethering App For Creating HotSpot In Older (Samsung) SmartPhone

EmDeEmDe Posts: 10FreedomPop Newbie
edited February 2016 in Tips #1
Hi, i'm using older smartphone Samsung Transform SPH-M920, it has Android 2.2.2 Froyo.

I have tried Sprint's own app "Sprint Hotspot", it stops 3G connection and fails to create a hotspot router/sharing functionality.

Then I have attempted bunch of hotspot or tethering apps, from PlayStore, for this old android, and none worked :(
WiFi Hotspot Tethering, Share mobile Internet! 3G, WiFi Hotspot, mHotspot - Free WiFi Hotspot, Mobile HotSpot Free, etc.

FreedomPop's "Messaging" software requires a minimum Android 2.3.3+, so it cannot be installed in this phone. So currently i'm unable to receive any SMS or VOIP calls :( So if i can do tethering & turn it into a hotspot then i can use internet from my another non-Sprint older android phone, and use FreedomPop app from that.

I also want to share internet service into my laptop.

Basically i'm trying to share-internet from this old phone, like a slow-speed WiFi hotspot modem.

I would first prefer to do something without rooting it, so what app would you suggest & known to work.

If not working without rooting, then what root app & what hotspot app is suitable/better, for this phone.

Please help & provide solutions, THANKS in advance,
-- EmDe.

EDIT: i have changed the topic title words slightly.
Post edited by EmDe on
Tagged:

Comments

  • Tarkara HarrisTarkara Harris Posts: 5FreedomPop Newbie
    Dont think it will work unless u pay for the hot spots
  • Rich Sias (16th)Rich Sias (16th) Posts: 3,352FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    Sound like you've tried quite a few hotspot apps. Anyone out there know of some obscure app that might fix the deal ?
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    Looks like TrevEMod would be a good option if you're considering rooting but if you'd like to stay as stock as possible I would suggest ClockWorkMod Tether or the stock tethering after paying for the FreedomPop tethering service!
  • EmDeEmDe Posts: 10FreedomPop Newbie
    strange, a mesg just got deleted automatically when i clicked on "Save Comment" ! so again reserving this post to move down previous post here, and then insert back original deleted post in above.
  • EmDeEmDe Posts: 10FreedomPop Newbie
    @Ali, Thanks. I was able to obtain Android-WiFi-Tether (also known as TrevE-Mod, and, also known just by WiFi-Tether), from a xda-dev user 1st, and then also from original source project webpage: https://code.google.com/archive/p/android-wifi-tether/ The 3.3-beta-2 version apk was created by Harald Muller, Sofia Lemons, Ben Buxton, Andrew Robinson, Joshua Briefman, Trevor Eckhart. This app needs a rooted phone, to create a WiFi hotspot. A user from xda-dev mentioned, long time ago in same phone, v3.3-beta-2 or a slightly older version worked fine.

    With default or "Auto" settings (in TrevE-Mod app), and later with any other manually chosen my settings, i have failed to share this-phone's internet :( with other-device. Here, by "other-device" i'm indicating toward a different phone, or a laptop computer, and NOT toward any Samsung Transform M920 phone.

    At some specific manually/custom chosen settings in TrevE-mod app, wifi hotspot (wifi wireless network) was able to start-up :) At that stage, if other-device's wifi connection mode was set to default "DHCP", then it was displaying "Obtaining IP-Address..." connection status message, then "Disconnected" or "Failed" etc was shown :( and these kept on repeating.

    When wifi connection mode was set to "STATIC" (instead of DHCP) inside other-device, and STATIC IP-address config from 192.168.1.0/24 LAN was specified, then other-device connected successfully & remained connected :) But still, this-phone's internet access was not available :( to any apps inside other-device.

    A network ping into any domain-name or ping into any web-server's IP-address, both failed. I have used LanDroid app for ping functionality.

    The "Log" option inside Android-WiFi-Tether (TrevE-Mod) app often displayed many errors, and number of errors varied with different phone "profile" option, but one error related with "routing" was always present.

    When i tried or tested any tethering app or a hotspot app, then firewall app was kept disabled.

    The "LanDroid" & "Network Info II" apps were used to view network info.

    When i'm displaying IP address, the shown "x", "y", "z", etc alphabets are used to mask or hide rest of the actual numeric portions, for safety+security purpose. Actually it is a number inside this-phone, but shown to other users in this webpage as an alphabet.

    When WiFi-Tether TrevEMod was enabled to create WiFi Hotspot, and when 3G connectivity was still working inside this-phone, then this-phone's internal network info showed these, and i'm also showing TrevEMod's config:
    • TrevE-Mod: Profile: Samsung Droid Charge. Setup Method: Auto (in Log it shows, it used "softap"). Enable WiFi Encryption: selected. Channel: 1. WiFi-Driver-Reload: selected. Change LAN: 192.168.1.0/24. Preferred DNS: 8.26.56.26, Alternate DNS: 68.29.x.y
      • Log showing: Loading (all)... done. But these 2 items "failed": Activating WiFi interface, Enabling Routing fix.
    • Network Interfaces : wl0.1 : 192.168.43.1 , ppp0 : 70.6.x.y , lo : 127.0.0.1
    • Device IP: 192.168.43.1, External IP: 70.6.x.y
    • IPv4 routes:
      • IPv4: 192.168.43.0/255.255.255.0 dev wl0.1
      • IPv4: 68.29.x.y/255.255.255.255 dev ppp0
      • default via 68.29.x.y dev ppp0
    • IPv6 routes:
      • ::/128 dev lo
      • default dev lo
      • (GW) fe80::/64 dev eth0
      • (GW) fe80::/64 dev wl0.1
      • IPv6: From LanDroid: fe80::3816:x:y:z/128 dev lo. From Network Info-II: wl0.1 : fe80::3816:x:y:z/64 Scope: link
      • IPv6: From LanDroid: fe80::3a16:x:y:z/128 dev lo. From Network Info-II: eth0 : fe80::3a16:x:y:z/64 Scope: link
      • (GW) ff00::/8 dev eth0
      • (GW) ff00::/8 dev wl0.1
    Does the TrevE-Mod config & Log look ok ? :grey_question: Does these route tables look wrong ? :grey_question: With these settings & config, Hotspot can run inside this-phone, it is also visible in other-devices, internet works inside this-phone, and other devices can connect with hotspot using a STATIC mode (not via DHCP mode) IP, but other-device still cannot access this-phone's internet :( :(

    EDIT: Feb-2, 2016: i moved rest of the message into next posting.

    EDIT: i just found out, i should have tried to do this http://www.androidpolice.com/2010/10/05/android-wifi-tether-app-for-rooted-users-constantly-disconnecting-try-these-solutions-to-fix-it/
    I will post result here later.

    EDIT: Feb-3, 2016: adding wifi-tether config info, route info, in above.
  • EmDeEmDe Posts: 10FreedomPop Newbie
    As above steps failed in this-phone (here, "this-phone" means the Samsung Transform M920 phone), so i have attempted other apps. And by "other-device" i'm indicating to a different phone or to a laptop computer, and "other-device" is not indicating to my Samsung Transform M920 phone.

    Loaded the "Free Tethering Unlocker (Root)" app (by Marco Visin) from google PlayStore. And ran it once.

    Downloaded & installed "PdaNet+" v4.18.2 apk (created by June Fabrics Tech), from http://foxfi.com/bin or from http://pdanet.co/android/ website, because Sprint unlisted/removed PdaNet+ & similar many other tethering & hotspot apps from google Playstore for sprint carrier users, to force sprint customers to use sprint's paid internet-sharing tethering & hotspot services. PdaNet+ app can start-up, but touching anything on screen, causes it to crash ! :( but it's menu option worked, which had "Help" & "Hash Code" options (to enter purchased hash code, and purchaser's email address) ! I think, free edition has some type of usage time duration based limitation. But anyway, it crashes ! :( PdaNet+ app is suppose to allow Bluetooth or USB tethering, without rooting the phone. I have noticed, PdaNet+ app need access to VPN service. This app was suggested by another user, for using on Android 4.0.3 based phone. I really wanted to share this-phone's internet via bluetooth, because enabling WiFi on this phone, was turning off the 3G/wimax wwan connection :(

    So i had to load the "FoxFi (WiFi Tether w/o Root)" v2.17.2 app (by FoxFi Software), and "FoxFi Addon" app, from google PlayStore. FoxFi's authors are now probably working with authors of PdaNet+. FoxFi app is suppose to allow WiFi tethering, without rooting the phone. I have noticed FoxFi does not need access to VPN service.

    I started the FoxFi app, specified a new SSID name (wifi/wireless network name) for this phone's WiFi hotspot, and setup a new password (WPA2). And clicked on "Activate WiFi Hotspot" option. It started the wifi hotspot (wifi-AP) successfully with very ease, which was also visible in other devices :) And then i chosen the "Enable Proxy" option from it's menu, (and it displayed a message to point web-browsers toward the proxy 192.168.43.1:8000). The "Sprint HotSpot" app started-up automatically in the background and was shown as an icon in the notification-area, but it was left alone (that is, it's hotspot settings were not touched / not enabled / not activated).

    In this-phone at this stage, Mobile/3G/wimax tower internet data service still worked fine in UC Browser, PlayStore, etc apps, and phone's internal wifi hotspot was also enabled :)

    In other-device, i tried to connect with the new-hotspot's (new wifi-network's) ssid (wifi-network-name), with IP-address configuration mode set into "DHCP", which is default/auto settings for most device's OS), then at 1st, though other-device was not able to connect with this-phone's hotspot :( but after few attempts, connection succeeded :) but internet access was still not available :( in any app inside the other-device.

    Inside this-phone, in FoxFi app, any connected other device's wifi MAC address & connection time-duration was appearing inside a blue colored list. And i have enabled sound features, so it made sounds when a device connected or disconnected.

    After some web searching, i found out, FoxFi app can begin it's DHCP allotment starting from IP-address 192.168.43.28. And beside, the "Network Info II" app in this-phone was also showing that, this-phone's ip-address had suddenly changed from sprint assigned public ip-address, into (a class-c network IP-address) 192.168.43.1, exactly when wifi hotspot function was enabled inside FoxFi or TrevE-Mod app.

    So in other-device, i've selected this-phone's hotspot wifi network-name, and clicked on "forget" option to remove/delete it, and again connected back with this-phone's wifi hotspot-name (or wifi-network-name), but this time "DHCP" option was changed into "STATIC" mode IP-address configuration, and following settings were specified inside other-device: hotspot ssid (wifi-network-name), hotspot password, STATIC IP: 192.168.43.28, Gateway: 192.168.43.1, DNS-1: 8.26.56.26, DNS-2: 8.20.247.20, Connect. After few attempts, connection succeeded & remained connected :) but still internet access was not available for any app :( inside the other-device. A ping into "google.com" failed inside other-device, and ping into 216.58.216.14 (google.com's one of the ip-address) also failed :( :(

    Any ideas ?

    i'm assuming, inside this-phone i need to check & add sometype of ip routing mechanism.

    EDIT: i think (i am suspecting), Sprint or FreedomPop or newer updated apps have done something, to disrupt the already-known to be working apps. We already know that Sprint unlisted certain apps from google Playstore for Sprint carrier users (while its still available for users of other carriers) to force users for their $$Paid$$ tethering & hotspot services, and Sprint software updates can also create crashes in certain apps & can block apps & services, (and in the same time, Sprint also allowed some tethering apps to remain in Playstore, obviously for their own ultimate benefit), so it is very likely that, same systematic implementations are maintained by Sprint mvno FreedomPop. FreedomPop app uses too many unnecessary system-level Permissions & Accesses !!! Youtube videos (and xda-developers forum pages) are clearly showing, how rooting was done & how tethering apps were used in 2011, in 2012, in 2013, on this same phone. And i have done exact same or very-close procedures.
  • indutaurusindutaurus Posts: 5FreedomPop Newbie
    Creating HotSpot In Older is for what??

    My boyfriend broke his phone so I let him borrow mine from time to time to make calls & text but when he tries to use other features or snoop around he can't hahhhaha!! I LOVE LEO Privacy!!
Sign In or Register to comment.