Trouble connecting to Internet

Ruth MellenthinRuth Mellenthin Posts: 13FreedomPop Newbie
I often have trouble connecting - it will either not connect at all, take a really long time, or pages won't load all the way. This seems to happen on weekends and evening, when I think there may be a lot of usage, but I have NO problems connecting on my phone, which is Virgin Mobile (Sprint Network).
I have a Ubee stick. I do check frequently for updates.

If I can't get a good connection when I need it, I will have to discontinue the service. Please advise.

Comments

  • Jorge Jorge Posts: 3,387 admin
    Hello @Ruth Mellenthin I apologize for the lack of support you have experienced thus far. I will be glad to have a forum agent take a look into your account to make sure everything is in good standing on our end :) Please check the email associated with your forum profile as an agent will contact you. Replying to the email from support can be done as you would a regular email (no need to log-in into Zendesk).
  • Ruth MellenthinRuth Mellenthin Posts: 13FreedomPop Newbie
    Hi Jorge, I don't know if you will see this, but I'm having further troubles!
    I ordered a new device, a TriFi hotspot, then my service was cut off!! I called, got it back on, but they have only given me 500 mg. I paid for the 4g on 6/25, and only used part of it (maybe 1/4 at most). Can you help with this?

    Thank you for responding!!!
  • Jorge Jorge Posts: 3,387 admin
    @Ruth Mellenthin Please check the email associated with your forum profile as I had addressed your above concerns yesterday :)
  • Ruth MellenthinRuth Mellenthin Posts: 13FreedomPop Newbie
    Hi Jorge - or whoever sees this. I appreciate the help I've gotten so far, but I'm wondering when I will receive the TriFi hotspot. It has not shipped and my account was charged weeks ago!

    Thanks!
  • Ruth MellenthinRuth Mellenthin Posts: 13FreedomPop Newbie
    Well, I received a device - a Sierra (doesn't have a number on it). Pretty sure this is not what I ordered but it works.

    But I changed the password and now cannot connect!! I think this is stupid Windows 8 - it doesn't give me the option to type in a new password to connect Anyone have any idea what I can do?
Sign In or Register to comment.