Crippling slow speeds, can't even download FreedomPop Messaging app to make calls.

newbUser4NownewbUser4Now Posts: 32FreedomPop Newbie
My phone had problems & had to do a factory reset.
After it reboot & I set my settings, I updated the PRL update & Update Profile.
I'm getting 3G signal bars & they are ranging from 3 to 4 bars (out of 5).
I'm on the unlimited plan & I did go over the 1GB of data (all to set up apps which are now deleted due to the factory reset). I should still get 3G speeds.

I connected to the PlayStore after about 20 seconds & searched FreedomPop Messaging & after a few seconds the page loaded.
Now the actual download has been going on for 40 minutes & still hasn't finished downloading.
I tried once before & it timed out & gave me an error saying I couldn't finish the download.

I estimate that the speeds are so slow that it would take a few minutes to download a single 1 MB file!
Even before the factory resets the speeds were beyond slow, but now I can't even download the freedompop app at all.
Are the speeds being throttled to the point I can't even download a simple text file?

How can I fix this? I also have no access to wifi currently.
Sign In or Register to comment.