My phone, not my account?

Joel CarenJoel Caren Posts: 2FreedomPop Newbie
I bought a reconditioned FreedomPop Galaxy S3 on Ebay, thinking it would prompt me to activate it and then I would use it. However, when I received it, I couldn't connect to the network, and the IMEI was listed as "active" (this was supposed to be an unused phone). After connecting to WiFi, it downloaded and installed a system update, and viola! I could now make calls. Great! Except that the phone number is for California (I'm in W. Virginia), and the name on the account is not mine!
I tried to contact FreedomPop through an e-mail address they've responded to before, but with no luck. Has anyone had this happen when buying a FreedomPop phone? How did you get it sorted out? The active service is a non-free one, so I'm sure the guy's going to ticked off when he gets the bill.
Oh, and I've tried to contact the Ebay seller and they're not communicative either.

Best Answer

Answers

  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    @Joel Caren
    Are you referring to the Name and phone number in Settings->More->About Phone? Those do not matter to you, but are used to connect Sprint data.

    Is the account info in the FreedomPop Messaging app yours?
  • Joel CarenJoel Caren Posts: 2FreedomPop Newbie
    @djinks No, I am referring to the account info in the FreedomPop Messaging app. I won't give the name in an open forum, of course, but my guess that it was a previous owner.
    I suppose there must be a way to take my phone off that other guy's account and put it on mine.
    @Ali I will try that number. I've heard the hold times are horrendous, though...
    Thanks both of you for your responses!
  • Anthony De GarateAnthony De Garate Posts: 1FreedomPop Newbie
    Joel, I'm having the exact same issue. How did you get it resolved?
Sign In or Register to comment.