**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Virgin Mobile Kyocera Rise - will not activate

James ChoateJames Choate Posts: 2FreedomPop Newbie
The MEID for my VM Kyocera Rise was accepted, so I paid my $19.99 to have it activated on FreedomPop. Turned it on and left it on overnight - and it's still not activated.

Tried the MSL carrier unlock step - it removed the old VM phone number from the device, but it's still not on FP.

Cannot perform the "Update PRL" or "Update Profile" steps, because those options are not available from the System Updates menu on the phone.

Is there something else I need to be doing? Is it simply not compatible (and if so, why was the MEID accepted?)

Comments

  • James ChoateJames Choate Posts: 2FreedomPop Newbie
    Apple from support emailed me - she shows my account is active and suggested I go thru the BYOD funnel to activate my phone.

    The problem with that is that I already did go thru the funnel - that's how I was charged $19.99 and set up my account after providing my phone's MEID in the first place.
  • LogosLogos Posts: 9FreedomPop Newbie
    So did you ever get it working?
  • jameswangjameswang Posts: 9FreedomPop Newbie
    I have the same situation. Everything else is fine. I have no problem making getting calls with wifi or premium.

    Only The data is not working. I send the tickets Fp support want me to update phone and buy SIM card. But nowhere to update the phone and there is no sim slot on the phone. It is a 3G phone guess that is why no sim.

    Not sure anyone has resolution now.
Sign In or Register to comment.