**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Can't active LG G2 (LS980). Invalid card and activation failed

bbwaterbbwater Posts: 8FreedomPop Newbie
edited July 2015 in BYOD #1
I newly got a sprint LG G2 from eBay ~ clean ESN. I also got a SIMGLW406R sim. Everything went good on registering the phone from BYOD page. But after two days, I still get invalid SIM, activation failure errors and so on. Still no service and can't use the phone. Can you please help. Appreciate in advance!!
Post edited by bbwater on

Comments

  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    Did you do the Update Profile and Update PRL? What instructions did you receive after activation? There should have been several emails, one with setup instructions.
  • bbwaterbbwater Posts: 8FreedomPop Newbie
    I got welcome, receipt, and a thanks again ~this one lead me to support.freedompop.com page with setup help. I did following the instruction but no luck yet. I tried to update PRL but got network error. It has been 3 days after I create the account. Please help!!! thanks
  • bbwaterbbwater Posts: 8FreedomPop Newbie
    Yes I did. Can you please check status of [email protected]? Thanks again
  • [Deleted User][Deleted User] Posts: 12
    Hello @bbwater I was able to take a look at your account and the activation was not fully complete but I have gone ahead and activated your device successfully. Please attempt to use the device now as it should be working. :3
  • bbwaterbbwater Posts: 8FreedomPop Newbie
    Yes it is activated!!!!!! thanks sooo much!!!! Freedompop is always the best.

    Although there is one little thing may still need your help. for some reason I still get "invalid card" on my local screen and looks like I have 3G only not LTE. I doubled check my ICCID it looks correct. Can you please check for me? thanks!
  • bbwaterbbwater Posts: 8FreedomPop Newbie
    my iccid is 89011200000457838000. thanks again!
  • [Deleted User][Deleted User] Posts: 12
    Hello again @bbwater, I am so happy to hear that your device is activated! The ICCID that was on the account showed up differently but I have gone ahead and updated it with the one you provided me with. Please perform a PRL update on your device, I have provided you with the instructions below. :3

    1. Select the menu button (located to the right of the home button)
    2. Tap settings, then scroll down to system updates
    3. Select update profile and let it run fully (may take up to 90 seconds)
    4. After the network profile is updated, repeat the same steps, but this time select update PRL instead of update profile
  • bbwaterbbwater Posts: 8FreedomPop Newbie
    Did it bunch of times but still no luck.... Any other suggestions? ~ 3G works. I basically I am very happy very :)
  • bbwaterbbwater Posts: 8FreedomPop Newbie
    btw, it shows Sprint as service on my lock screen first. then goes as invalid card after a while....
  • [Deleted User][Deleted User] Posts: 12
    Hello @bbwater I will be creating a ticket so one of our forum agents can take a closer look into this issue. Please check the email associated with your forum profile as an agent will contact you. Replying to the email from support can be done as you would a regular email (no need to log-in into Zendesk). :3
  • bbwaterbbwater Posts: 8FreedomPop Newbie
    awesome thanks!
  • DROOF23DROOF23 Posts: 16FreedomPop Newbie
    I've had that problem where I get 3g but no lte since day 1. Everything like iccid is correct and I've done everything that could possibly fix it and nothing works. If you or anyone else ever figure it out let me know. BTW my phone is an lg g2.
  • matthew hallenbeckmatthew hallenbeck Posts: 1FreedomPop Newbie
    same problem with LG G2 invalid SIM. I can't seem to get either help in the forum or from support to fix it. My S3 worked great but this is frustrating.
  • GingerGinger Posts: 4FreedomPop Newbie
    Why is it that searching the forums for [LG Invalid Card] does not find this thread, but searching for [Invalid Card] does find this thread?

    We recently purchased an LG Optimus F3 direct from FreedomPop. Login screen shows "LG|Invalid Card" directly above the "Emergency Call" button at the bottom of the screen. Updating the PRL and Profile and rebooting the phone clears this message showing only "LG" but reverts back to "LG|Invalid Card" a few minutes after the reboot.

    Phone seems to work despite this message, but I am wondering if it is not working as well as it could. (Call quality is generally not great, but I do not know if this could be related.)

    I have submitted this request via the support link (before I was able to post here).
  • GingerGinger Posts: 4FreedomPop Newbie
    Answer from support is to remove SIM card, clean contacts on card, reinsert and restart phone.
  • GingerGinger Posts: 4FreedomPop Newbie
    Reseating the SIM card cleared the error msg, but only for a short while. Called the support number and problem was diagnosed to be incorrect ID for our SIM registered in the FreedomPop system. Info updated on server and after a few reboots, the phone is working great with no error messages. Even seeing the 4G icon in the status bar; which I had not seen before, but did not know I was missing.
Sign In or Register to comment.