**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

HTC Evo error, your device isn't compatible with this version.

Sandeep MangrulkarSandeep Mangrulkar Posts: 8FreedomPop Newbie
I had to hard reset my Evo and now when I try to download the messaging app from play store, I get 'your device isn't compatible with this version'. I have hard reseted the Evo again but same error. The old version of app working fine. How can I resolve this issue or download old version. My Evo is on latest version 2.3.5.

Also how can I contact Technical support? Is it through this forum? Or need to call?
Post edited by Sandeep Mangrulkar on

Comments

  • johnmjohnm Posts: 99FreedomPop Newbie
    same with me, version 17 is not compatible with 2.3.5, so now what?
  • Sandeep MangrulkarSandeep Mangrulkar Posts: 8FreedomPop Newbie
    Any help from admins is appreciated. How to get old/ Evo compatible apk? Instead of getting from non legitimate sources on inetrnet, I would prefer if admins help and sort out the issue.
  • James DemersJames Demers Posts: 7FreedomPop Newbie
    Same problem with two of my kids' phones. Please help.
  • James DemersJames Demers Posts: 7FreedomPop Newbie
    Is it possible to post the APK of the last Freedompop app that will work with the HTC EVO 4G so I can reinstall this on their phones please?
  • John-Y TranJohn-Y Tran Posts: 1FreedomPop Newbie
    Has anyone got an answer or correct apk yet.

    If I knew this would be an issue, I would not have done a hard reset.
  • Sandeep MangrulkarSandeep Mangrulkar Posts: 8FreedomPop Newbie
    I agree. Need to reach out to customer care for help.
  • Feng ShanFeng Shan Posts: 6FreedomPop Newbie
    Why don't I see any answers here. Where are the tech support? I've had the same problem.
  • ramdxenramdxen Posts: 169FreedomPop Newbie, FreedomPop Expert ✭✭✭
    @Feng Shan, there is no real way to answer the concern, as it's moreso an issue that needs to be alerted to those that make the app in question. Only the current version of the app is officially supported and has an expectancy of full compatibility with the current setup. What I can tell you is I have run into this issue before with other apps, and was able to get around it (in android) by installing the apk directly. Since this means going outside of google play, it poses an obvious security risk. To even do this, androids (I don't know i-stuff) need to enable installing from unknown sources (check in android's security settings). From that point you'd need the apk to see if you can install it directly. If you're unable to get the apk (if rooted on any device that accepts it, is easy to install, backup, and send the backup to your device with the issue). I could, technically, send you the one I have installed, but please understand it is generally advised to never install anything from sources you do not know are trustworthy.
  • ramdxenramdxen Posts: 169FreedomPop Newbie, FreedomPop Expert ✭✭✭
    I'll just make a new post instead of editing the above one and then explaining the edit. A generally trusted source for apk files is apk mirror. I don't believe they have the latest, version 20, but they do have recent versions. Some mobile browsers have issues with downloading apk files, again, it is a security risk, but by trying diffeerent browsers or transferring from a pc you should be able to skirt that issue. No guarantees this wil work, but if you need to use your FP number and can't, it's worth a shot. The link is apkmirror.com/apk/freedompop/
  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    Here is a post I created last year on the HTC that may help

    https://forums.freedompop.com/us/discussion/14395/everything-htc-evo-3g-cdma-only-connection-issue-user-guides-how-to-tutorials#latest

    This has the app version and how to download & Apply . This is currently the only version that will work on a HTC evo. BUT, Google might have stop support on Android 2.3. The Rumor a few months back, was an update to Google Service was coming out and after all apps that supported Android 2.3 would no longer work. I have given out the app version a few times since, and have not heard any feedback if it still works. All my HTC Evos are retired and in boxs :)

    Hope this helps!
    njfulwider5

    PS-App is from a trusted source! Post is one of many I have on FreedomPop Phone(I need to update)-

    https://forums.freedompop.com/us/discussion/14633/freedompop-phones-connection-issues-need-a-user-guide-click-here-for-how-to-tutorials#latest

    here is the one I have on Hotspot(I need to update)-

    https://forums.freedompop.com/us/discussion/14234/freedompop-hotspot-devices-connection-issues-need-a-user-guide-click-here-for-how-to-tutorials#latest

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

Sign In or Register to comment.