**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

I have data and text but no voice service.

Ahmad SheikhAhmad Sheikh Posts: 1FreedomPop Newbie
I am a new user, I have my account activated a couple of days ago. I got data and text but no voice. Every time I use the messaging app to dial a number I get the message "service is currently unavailable. Please try your call again later". I tried to reset the phone, do the hard and soft reset and followed instructions on several posts to do reset on the network but all that did not work.

Answers

  • dwight goliday jrdwight goliday jr Posts: 42FreedomPop Newbie
    You know, you dont have to use the default dialer to make a call right? Or are you saying you are unable to dial out at all? If this is the case, try to download the Google Hangouts dialer app or use skype or facebook dialer apps.
  • djinksdjinks Posts: 1,270FreedomPop Newbie, FreedomPop Expert ✭✭✭✭
    If you can access the internet with a browser, then you have connectivity, so the problem is in the VOIP app, FP Messaging.
  • Ronald HolderRonald Holder Posts: 15FreedomPop Newbie
    After I updated my phone to Android 5.1, I was getting those messages. I had to go into Messaging and sync my data, that fixed it for me. But check that you have entered your username and password from FP correctly, see if your account info appears to be correctly displayed, and try the FreedomPop Diagnostic app to figure out what might be wrong - you will find that in Google Play store.
Sign In or Register to comment.