**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

An unexpected error occurred processing your order

Sara ALLENSara ALLEN Posts: 4FreedomPop Newbie
stuck on final step to activation with iphone 5s. this is the error message. have tried multiple times. what is going on?

Comments

  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @Sara ALLEN Please try using a different credit or debit card and it should work :)
  • Sara ALLENSara ALLEN Posts: 4FreedomPop Newbie
    yeah, nope. We did this as you told us to, and it charged ALL our credit cards. EVERY time we tried (and apparently phone activated once), though it didn't work. My husband spent hours on the phone getting it fixed. Works now, but we are still trying to make sure all the charges didn't go through. And Freedom Pop said WE have to stop the charges. I'm sorry, but when your system malfunctions and repeatedly charges credit cards while saying the transaction didn't go through, that is YOUR problem to fix.
  • ronnronn Posts: 2FreedomPop Newbie
    It happened to me too. Tried 5 times just to find out that I was charged all 5 times and still no activation. Oh, and yes, I used different credit cards...
  • pxfbirdpxfbird Posts: 2FreedomPop Newbie
    I had the same thing happen to me. Tried it four different times and was charged all four times. Then it would give the same error message. It shouldn't be this hard to activate a device and order a plan! My device still isn't active.
Sign In or Register to comment.