Can't activate my Sprint EVCO 4G

UUMickeyUUMickey Posts: 0FreedomPop Newbie
Hi, FreedomPop folks. I've been trying to activate my BYOD Sprint EVO 4G and when I enter the MEID DEC (as shown in the help photo on the activate page) I keep getting the error "Please enter a valid Mac Id".

I am not sure what else it wants. The phone has been deactivated from Sprint for well over a year. It was in good standing when I left Sprint and bought a Galaxy S3, so it's just been sitting in a drawer.

Is there some other value it wants in the "1) Enter your device's MAC Address or ESN (e.g. "001E31700454")" box? If so, where do I find it since the number in the help isn't being accepted?

Thanks.

Comments

  • M.A. II LopezM.A. II Lopez Posts: 1,163FreedomPop Master, FreedomPop Expert ✭✭✭
    @UUMickey‌ pm @Taylor‌ now so you can be in his que for assistance. In the mean time perhaps one of our other "Pro" might happen by with assistance you can try.
  • UUMickeyUUMickey Posts: 0FreedomPop Newbie
    Solved my own problem :) It was the main link having some kind of invisible captcha action. I found another link (also via the forums):

    freedompop.com/discountbyod?utm_source=freedompop&utm_medium=forums&utm_campaign=discountbyod

    That one worked fine and I am already up and running. Thank you for following up.
This discussion has been closed.