**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

BYOD Samsung Galaxy 4S not activating

rcignoni5302rcignoni5302 FreedomPop Newbie Posts: 1
I purchased a used Sprint Samsung Galaxy 4S in a private sale, signed up for a FreedomPop account using the MEID and the ICCID, paid the $19.99 device fee, and now I have a phone with no FreedomPop account. No calling, no text, no data. Phone number isn't registered properly. What do I do?! Help!

Answers

  • Benjamin TuominenBenjamin Tuominen FreedomPop Newbie Posts: 10
    Hate ride your coat tails but the same thing happened to me. Bought a good clean eBay phone, HTC EVO 4g. MEID checked out fine and activated over the Freedompop website. They took my 19.99 activation fee and sent me my PRL code. Phone looked like it activated fine but it has the wrong phone number and I can't dial or text anyone even though I'm connected to the network.
  • Jorge Jorge Posts: 3,371 admin
    Hello @rcignoni5302 I took a look into your account and it does appear that you were able to speak to one of our support agents. To reiterate what the agent advised, please make sure you have downloaded our latest messaging app from the Goggle Play Store. You will need the messaging app in order to make calls and texts. If you have more questions please let us know and we will be glad to further assist you :)

  • Ali Ali FreedomPop Master, Test Role, iOS Master Posts: 6,735 ✭✭✭✭✭
    @Benjamin Tuominen Hey there Benjamin, you will need to download an older APK to use the phone app. You can get it here - http://apkhouse.info/download/398778
  • Benjamin TuominenBenjamin Tuominen FreedomPop Newbie Posts: 10
    Awesome, thanks Ali. I'll give it a whirl and report back.
  • Benjamin TuominenBenjamin Tuominen FreedomPop Newbie Posts: 10
    Hey Ali. I went ahead and installed the APK as you recommended and I still am having the same issue. When I go to use the FP app it tells me I require a different version of the messaging app. Of course I can not install this version because I'm on Android 2.3.

    Anything else you can recommend? BTW, yes, I did restart my phone after installing the older APK you mentioned.
  • Benjamin TuominenBenjamin Tuominen FreedomPop Newbie Posts: 10
    Okay, I've managed to get into the older messaging app and it's asking me for my email address. I'm using the same one attached to my account that I signed up with and it's telling me it's invalid.
  • Benjamin TuominenBenjamin Tuominen FreedomPop Newbie Posts: 10
    Still the same thing. I've changed my email address 3x because I've read it won't take it with a period in the name field.

    The older messaging app will not accept my email address.

    The newer messaging app version 17+ for android 2.3.4 and up lets me in but won't register the device. It registers my correct phone# and account info. However, It gets hung up on registering for push notifications.

    I've done a factory reset on my phone before I installed the APK's and also restarted after installation.

    I've also waited just to see if it was the speed of updates in the system. That didn't work either.
  • Benjamin TuominenBenjamin Tuominen FreedomPop Newbie Posts: 10
    Tried again this morning, still coming up with the same issue.

    Account not found:
    Please check your email address and try again.

    4 days so far and no service, even though I'm activated.
Sign In or Register to comment.