Can't call my home number

Litsu RehakLitsu Rehak Posts: 8FreedomPop Newbie
I just received the Kyocera Hydro Icon today with the free 200 minute, 500 text, 500MB data plan and free premium voice trial. I don't seem to have any problems calling or texting, but when I try and call my home number (Time Warner VoIP) while at home, I get a call error in the Freedompop ap that says "There was an error placing the call to +1915xxxxxxx. Please check the dialed number for errors and try again." I called and spoke to customer service earlier today and they said since I was able to make calls to other numbers to give it a couple hours and it should start working. That was almost 4 hours ago. I have tried with WiFi and data enabled, just WiFi, just data, and with neither (premium voice)...nothing has worked. I was successful in reverse (calling the cell phone from the home phone while I was in the house). Tomorrow, will try to call home number while I am running errands, but if unsuccessful, don't know what to do as the number I would be calling most is home.

Best Answer

Answers

  • Litsu RehakLitsu Rehak Posts: 8FreedomPop Newbie
    The home phone service with TWC has been set up since February. I ended up getting two Google Voice numbers, forwarded one to the TWC number and forwarded the other to my FP number since we seemed to be hit and miss calling FP number from home as well. Seems to be working although it's a shame to have to have such a workaround. Thank you.
Sign In or Register to comment.