VPN on s3?

xIce52xIce52 Posts: 3FreedomPop Newbie
Soo. I want to connect to MY vpn, not freedompops, and it won't let me.
I am not the only one having the issue according to google..

https://forums.freedompop.com/discussion/3430/unable-to-get-my-vpn-working-on-new-s3
https://forums.freedompop.com/discussion/6628/getting-openvpn-to-work-on-s3
https://forums.freedompop.com/discussion/5450/can-i-root-my-freedompop-provided-s3
https://forums.freedompop.com/discussion/3606/my-new-s3-is-working-well-except-for-vpn-privacy

We need a fix for this FP.. Everyone using FP with a galaxy s3 is having the error. Could it be possible that FP decided to supress VPN settings, so we are forced to order THEIR vpn service? I have my own VPN and I don't want to use FP's vpn by force for more extra money. Willing to root phone or something if it's an absolute must, because having a VPN is an absolute must too. The VPN I want to connect to is my Private Internet Access VPN. I checked the username and password atleast 10 times, and the VPN DOES work on my other devices, and works for other galaxy s3 users that are not a part of FP.

I tried PrivateInternetAccess app, and when I tried to connect to my VPN, nothing at all happens when I press connect. The button changes from connect to disconnect but below it, it says i'm not connected to the VPN. I checked whatismyipaddress.com as well, and sure enough, my IP didn't change.

I tried OpenVPN, and when I tried to connect to my VPN, I just get this error:


I tried using Androids VPN settings itself, and whenever I press connect, the connect button changes into a disconnect button. For 0.5 seconds. After 0.5 seconds, the disconnect button immediately changes into a connect button.

What is going on? Paying FREEDOMPOP to use OUR own VPN is outrageous (if they supressed the VPN feature).
None of the threads I listed ever got a real answer, so i'll keep bumping until I get a working one.

Comments

  • xIce52xIce52 Posts: 3FreedomPop Newbie
    If it matters, build version is 1.01.08.1119.
  • xIce52xIce52 Posts: 3FreedomPop Newbie
    Digging more information up.. While searching in system/app, VPNClient.apk is missing. Is it safe to just upload VPNClient.apk from a later version of freedompop rom into it?
  • Marina CMarina C Posts: 3FreedomPop Newbie
    I'm having the same problem.
Sign In or Register to comment.