Samsung Galaxy S3 - Wifi won't turn on

This is our second S3. So the replacement phone can't seem to get the Wifi to scan for hotspots. It won't detect any hotspot. I've tried downloading the Freedom Pop Wifi, and it can't find a hotspot either. I don't know what to do.

Comments

  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    @Loren Mallory

    Just a quick suggestion-Go into settings-->>Connections Tab-->>More Networks-->>Mobile Networks-->>Connection Optimizer.

    Click the connection Optimizer and make sure Sprint Connection Optimizer is on.

    Make sure when your in Mobile Networks, That Airplane mode is not checked.

    If you can get any type of wifi connection....Make sure to go into your settings-->>More Tab--->>>System Update---->>>Update Profile....wait for the restart....--->>Than Update the PRL.


    If your still having issues----Try connecting to 4g and attempt a profile and Prl Update.

    Test Your Wifi(Any Phone)
    Great way to make sure you have a phone working with wifi----Find a McDonalds or a Local Library. Both places offer free wifi.

    Hope this helps.

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

Sign In or Register to comment.