Advanced Tech Help

Cliff RileyCliff Riley Posts: 6FreedomPop Newbie
Okay so I opened a regular ticket, and had a back and forth over email [Incident: 151023-001190], I had no 3g/4g data on Cyanogen, flashed back to stock 4.1.2 and I'd be able to get 1x data service only. Did all the standard PRL/Profile resets, even did carrier reset and basic activation cycle again, still nothing. Finally had support update incorrect ICCID and would get 3g in stock sprint firmware, but still when I flashed forward to Cyanogen no data at all. Recontributed to email to reopen ticket, they responded with basic copypaste of 'tickets closed, feel free to reopen or call us if any more issues' line 4 days later.

Before the ticket/email got the first response 2 weeks had passed, so I called, and of course support doesn't accept the fact that I did all the carrier reset and profile prl stuff, so it's half hour of 'please do this now and let me know when it's done' but don't know how to respond to 'I just did that' as a power user knowing this stuff already, so I quickly gave up with that.

I made religious backups of both the entire rom/modem/boot from recovery, and also backed up efs.img and a export of the NV items after putting in the Diagnostic Password and SPC/MSL into the PC tools. Somewhere in one of the APN and Band tweaks or in a stock flash I was trying out I corrupted some of the efs/nv data. Had the 'no radio' issues. Figured I'd just as easily restore the backup of those values since that was what they were there for. That made things better and worse, for some reason now my SPC/MSL is something completely different than was active before the restore and in the backup restored to it. The new one I extracted is denied in the pc tools as incorrect (tried old one and default and 000000 as well), but on the phone I can ##{msl}# and it opens the embedded menu.

After a fresh ODIN up from MD5 (4.1.2) to ND8 (4.4.2) with new modem and firmware set, then a EFS/NV wipe and 'rebuild' in the factory menu, I had a blank slate but at least had radio detecting. Plus the rebuild gave me a stock MSL of 222222 which worked both in the dialer and in the tools which let me insert up all my esn/meid information again, and got PRL and Profile to update again and be detected on network.

At this point, with APN zip patched in, I get 3/5 bars of signal, FreedomPop detected as carrier on the tray and menu, but the Diagnostic App says '2g' is all it gets, and can't browse even a blank or simple page like google.com on browser, but it does have enough data to load up the Messenger app apparantly, since it did 'Locating User...' and gave me my phone number and the pull out menu shows my data and minutes limits accurately.

Still no 3g or 4g though... at this point I think it must be on FreedomPop or the carrier Sprint's side of authorizing the device properly since carrier reset and profile doesn't fix it and while profile is mostly 3g data information pulled down and wouldn't help with 4g, 3g doesn't work so that means it's further up the chain of not even sending the right authentication information.

Comments

  • Robert ZimmermanRobert Zimmerman Posts: 95FreedomPop Newbie
    edited November 2015 #2
    Question: have you looked over this thread and did you use the APN zip that Merudo provided on XDA or a different APN patch?

    The below is written under the assumption that you're still running on CM, since I'm confused as to what ROM you're running (I got lost reading that):

    It's also worth noting that a lot of people in the d2spr thread on XDA complain about CM 12.1 having data connectivity issues. They even complain about connectivity for later builds of CM 11... So if you have tried the above, it might be worth flashing another ROM to check and see if it's just a CM thing. Or you could flash back to stock to see if using your latest semi-success with the PRL update and the APNs translates into a fully working solution (since it doesn't sound like you've tried that?).

    Also, a random thought: if your MSL changed and Samsung's MSLs are based on your MEID/ESN, it could mean that your phone thinks its MEID is different, which is causing it to fail registration of FreedomPop's end. Nevermind - totally missed the part about reinserting your MEID.
  • Cliff RileyCliff Riley Posts: 6FreedomPop Newbie
    I've given up on Cyanogen for a while since no point in trying to go back up to what I had if I don't have data, (plus thought I'd give Android Pay a try, since that's not available on Cyanogen). I'm on Stock Sprint ND8 (4.4.2).

    I've tried all the different APNs I could find Merudo one I had tried, also tried one later in those threads that instead of "FreedomPop APNs Fix.zip" I found one "FreedomPop APNs Fix 2015.zip", and I even tried "Stock FreedomPop Rom APNs.zip" taken straight from a fresh FreedomPop Rom.

    When 12 and 12.1 Cyanogen came out yeah even I had problems on other phone, but wasn't anything a downgrade and reflash and APN fix flash didn't fix. At this point though this is two identical phones, my partner has an identical GalaxyS3 that I was setting up at the same time, and hers with the latest nightly 2015/10/28 Cyanogen 12.1 Lollipop and APN fix works beautifully, full 4g 3g and proper carrier name. But when it came to mine starting at the same stock firmware, same model, same flash and patch order just repeated, got different result.

    I get only 3g icon in the top status bar, but that's definitely not even 3g speeds, it's loading data for apps at lower than dial up speed (trust me I know what that is, I've had it until a few years ago), and the FreedomPop Diagnostic app says it's 2g connection, which I'd believe with not loading anything in browser but works with simple apps like the FreedomPop Messenger able to load up the data usage and minutes left information.

    I can't get any more clean stock than this, I have root installed (but hidden/disabled) otherwise it's stock recovery, stock ND8 rom, sprint bloatware, knox, the whole shebang.
  • Robert ZimmermanRobert Zimmerman Posts: 95FreedomPop Newbie
    edited November 2015 #4
    Hmm. If you have already tried the APNs from FreedomPop Stock ROM APN list, I can only think of one other thing to check: have you reverted back to the stock modem firmware? I'm not familiar with ODIN, so I'm not sure if it flashes modem images automatically.

    If you are indeed back on the original firmware for the modem... I'd suggest looking at this post on the CM forums. I didn't see any mention of QPST or SGS3 in your posts and several CM users (in the original thread) noted that following those instructions was what fixed their data, not just fixing the IMEI with Qualcomm NV after an accidental corruption/wipe.

    edit: grammar
    Post edited by Robert Zimmerman on
  • Cliff RileyCliff Riley Posts: 6FreedomPop Newbie
    I didn't realize before that forums had a separate little dropdown hidden button to post as a 'ask question' instead of what this is as a 'discussion'. Do staff even look at these or only if they're a question? Can this get moved/converted by the approval helpers/staff to the proper type? Should I just repost in that question category?


    With all the id's and settings and apn's configured, I can only guess that the last things I can't read from the phone that are also used in the authentication with the towers, would be the HA secret and AAA shared secret, not sure if those send and handshake with activation process (which means I need a refund and go through the activation procedure again), or if FreedomPop even has those on their file or if I have to somehow talk to a higher Sprint employee (does MVNO's still go through Sprint master database for that stuff?) to get that given to me?

    From what I see almost nobody else on any updated firmware from the very first edition of the modem/baseband firmware can read that from phone, the sim and stuff refuse to give it up even with SPC + Diagnostic Passwords sent to phone, but supposedly they still write fine. But there's no way to check what the old one was and it didn't export with the backup, so with a complete NV/EFS wipe/format of the memory, I think those keys got lost. With ESN/MEID/ICCID all confirmed with support, and all the APN and stock rom all a mirror of what it was when working, that's the only thing I can think of not working is one of those deep other codes that normally don't get tampered with and so are invisible to basic support staff that read a script and don't know what the difference between a Profile update and Carrier Reset are, and only just know to tell you to do one and if it doesn't work do the next. I've given up on Freedompop phone support, each time I upfront tell them I've done this and that all the resets and clears minutes before I call them in preparation being an advanced user, and I just get basic support that walk me through it all again. So I sit there, count to ten and tell them I done it, and it goes on for an hour of this stupid walkthrough before I get them to just admit that's all they can do, annnnd... that's about it. I can never get escalated to some kind of geek about phones that knows every little in and out of programming and servicing. These weren't bought from a retailer, so I can't go and just do a phone swap or some other swap out. Nothing is wrong with it hardware-wise, not like it's blocked or banned or bad esn, I mean it's activated fine as far as the website let it, so a replaced device isn't going to help any more even if I had some kind of warranty to do so.

    With the ICCID being wrong on FreedomPops side and supposedly corrected, I wonder if the AAA Secret was also wrong and that the one got updated but the other only gets tied at the factory to the secret and that with that possibly wiped or incorrect, I can't read it to give it to FreedomPop, so I can only hope to get a private message with AAA sent to me to try to write to the phone. Unless the ICCID wrong on FreedomPops side was updated in their database but Sprints tower side still doesn't have it on theirs and so it's not authenticating to the towers meaning no 3g/4g service? Does FreedomPops 'updated' on their side carry all the way up to Sprints tower side through their API?
Sign In or Register to comment.