iPhone5s, 5 bars of Sprint 3G, but no internet, FP app says "Not Registered"

alan_iwaalan_iwa Posts: 20FreedomPop Newbie
edited November 2015 in Mobile Phone Service #1
Hi,
My phone gets plenty of Sprint Signal 3G -- 5 bars. But I can't get any internet connection. The Freedompop app is stuck "Not Registered" or trying to register (and failing). When I try to browse the web, there is a re-direct to setup3G.freedompop.com but it times out since there's no connection.

The phone works when I have wifi.

I have tried all sorts of resets and updates that I've read about on the forums, but it seems something is wrong with the account since the signal is good.

The service was working fine until a couple of days ago. Also, I believe I was getting 4G LTE on sprint, but now I can only see 3G. not sure if that's related.

Please help.
Post edited by alan_iwa on

Comments

  • RossfuzRossfuz Posts: 116FreedomPop Newbie, FreedomPop Expert ✭✭✭
    try using wifi to register the Freedompop messaging app. that's fixed it for me in the past.
  • alan_iwaalan_iwa Posts: 20FreedomPop Newbie
    It will register on wifi, but once I leave wifi range and switch to 3G the app will go back to not registered.
  • MishkoMishko Posts: 24FreedomPop Newbie
    @alan_iwa Sounds exactly like the problem I'm having on my LG G2. Would be nice to get an answer from someone. Resets, restarts, reinstalls, clearing caches, updating, etc., all of this doesn't work. Must be a button an admin needs to push somewhere in the back office to get us back on line.
  • alan_iwaalan_iwa Posts: 20FreedomPop Newbie
    I know. I sent an email to support Saturday. Hoping to get a response soon :)
  • alan_iwaalan_iwa Posts: 20FreedomPop Newbie
    edited November 2015 #6
    I got an email from freedompop support this morning. They said my account was suspended, but they re-activated and my phone is working! Yay!

    Still why was it suspended in the first place? I am a good citizen.
    Also why am I on 3G now. I'm not going to surf for videos (unless on wifi) anyway, but it still feels like I just got downgraded.
    Post edited by alan_iwa on
  • MishkoMishko Posts: 24FreedomPop Newbie
    Hmm, weird. I'm back up now, too, but with no explanation. I sure hope it wasn't because my account was suspended, I've only been with FP for six weeks now.

    You're still getting 3G not 4G LTE?? That stinks. I got the 4G service back.
  • alan_iwaalan_iwa Posts: 20FreedomPop Newbie
    Hmmm... maybe they say "You're account was suspended" as a euphemism for "We don't know what happened but we needed to reset your account." Good to hear you have 4G back! Hopefully I can get 4G in a different area. Still need to check.
  • Rich Sias (16th)Rich Sias (16th) Posts: 3,352FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    I checked last night at 11pm in Philly suburbs.
    In iOS I got a strange network error. On that page was an address: 4G.setup.freedompop.com. There was one link on that black & white page: Cancel. I clicked that. Hmmmm is the browser working ? I'll try www.ibm.com, YES ! www.microsoft.com YES! again.
    At least one of my Photons is working.
    Checking MyAccount, I see usage was last Nov4 3:45pm. No usage on Nov 10. So its more of a fluke connection rather than fully authorized.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
Sign In or Register to comment.