Can't hear receiver when WiFi turned on OR Not enough data being credited to my account

Trevor RialsTrevor Rials Posts: 2FreedomPop Newbie
So, I actually have two problems, and if I can get one solved, then I don't really care about the other because they're impacting me in the same way.

First, if I turn on my WiFi and make an outgoing call, then I am unable to hear the person that I called. They can hear me perfectly fine, it's just my end where I can't hear them. If a call is incoming, we can both hear each other. Therefore, the only way I can make an outgoing call is to turn off WiFi (which then uses my mobile data). I have unlimited minutes, so this wouldn't be a problem except...

Second, whenever I make calls using data, it appears that the "data" part of the call still counts against my monthly data with FreedomPop. It appears that FreedomPop tries to correct it by offering "Phone Call Data Credit", but they're not offering enough based on my calls. I had to make some very long calls yesterday, and according to my phone, the FreedomPop app used roughly 150 MB of data. However, I've only been credited 50 MB for yesterday leaving me with a deficit of 100 MB. Since I only have 500 MB per billing cycle, this is going to run out extremely quickly, so I need one of these issues resolved hopefully soon.

If I can make the calls on WiFi, then it doesn't bother me because I won't be using the data. Conversely, if I get the correct credit, then I don't care about turning off WiFi to make calls.

Any help is greatly appreciated. Thank you.

Comments

  • Trevor RialsTrevor Rials Posts: 2FreedomPop Newbie
    I wanted to follow up on this for anyone else who has the same issue. I got in touch with FreedomPop support. They're going to look into the issue with not crediting the correct amount for customers.

    As for the WiFi, when I turned off my firewall on my router, I was able to hear the person on the other end, so it definitely appears to be a router configuration. I haven't figured out the exact steps, but it's definitely related to the firewall.
Sign In or Register to comment.