No FreedomPop service after activation

netghostnetghost Posts: 1FreedomPop Newbie
Hello,

I have a Google Play Nexus 5 I've been previously using with a GSM-like carrier before. I wanted to activate it on FreedomPop, went through the BYOD wizard, it had some issues with my IMEI and I was instructed to call the 1-800 number. The rep on the other side took the IMEI and said it was ok. She created new account, took my CC details and activated the new service. I asked her whether I needed a SIM, and she said that FreedomPop doesn't use SIM cards (which is somewhat confusing since I found several I can go to the newly created account, but it doesn't list my device there, instead prompting to activate the new device. She instructed me to wait for 15 minutes and reboot the phone. I waited and rebooted the phone, but didn't any service.

When the phone turns on, it simply display the "no sim - emergency calls only" icon, and if I got to network settings, they are all greyed out because of that. Also, in the testing menu (*#*#4636#*#*) under phone info, it shows "LTE/GSM auto (RPL)" as preferred profile, and if I try changing it to CDMA or LTE/CDMA or LTE/CDMA/GSM, it doesn't seem to be applied, because whenever I go back to that phone info page, it's back to "LTE/GSM" option.

Can anyone please explain me whether FreedomPop does or does not use SIM cards and how to force my Nexus 5 to switch to CDMA mode so that it can see the FreedomPop network.

My FreedomPop account is fpnexus5[at]netghost.ca

Comments

  • @netghost

    I am currently assisting you through PM :3
  • jefe888jefe888 Posts: 1FreedomPop Newbie
    I'm having the exact same issue, but with a Nexus 6.
  • kennedyarkennedyar Posts: 2FreedomPop Newbie
    I have the same issue with a Nexus 5 as well. I was told over the phone that I needed a specific SIM, model(SIMGLW206R. However, even with that SIM, I can not register on Sprint network.
  • Joel_RJoel_R Posts: 1FreedomPop Newbie
    @Karina Magana

    I just signed up and I'm having the same issue as the OP, my Nexus 5 activated fine, but no service is found.
Sign In or Register to comment.