**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Bought Moto E 2nd Gen LTE but the phone says 3G

faithxiongfaithxiong Posts: 3FreedomPop Newbie
Hi

I bought a Moto E 2nd Gen LTE. The device settings also says it is a LTE in the phone info. However I have noticed that for the entire 2 weeks I am using the phone. When I am not using wifi the phone icon always say 3G and NEVER 4G or LTE.

Did freedompop send me the wrong model? Is this a 3G phone with 4G OS image installed?

Comments

  • comintelcomintel Posts: 310FreedomPop Newbie ✭✭✭
    Try a carrier data reset (in the menu accessible from Settings/Activate if you look for it).

    Also make sure it has a sim card and that the ICCID matches what your account says.
  • faithxiongfaithxiong Posts: 3FreedomPop Newbie
    Called customer support, the following worked for me

    Go to Settings > System Update

    Update PRL, wait for the phone to come online again
    Update Profile, wait for the phone to come online again
  • BuzbeeBuzbee Posts: 7FreedomPop Newbie
    Under
    Settings ->About phone

    Model Number should be "Moto E (2nd Generation) with 4G LTE"
    Hardware SKU should be "XT1526" (Single SIM) or "XT1524" (Dual SIM)

    The XT1511(Dual SIM) & XT1506 are 3G only.
Sign In or Register to comment.