**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Cannot get my new Kyocera Hydro to work? Help please!

Cameron JenkinsCameron Jenkins Posts: 32FreedomPop Newbie
Hello I have called quite a few times about my kyocera hydro that I just received in the mail. Multiple times we verified the phone is active and tried to update the PRL and profile. But sadly after the phone restarts I am without access to mobile data again. By this time the support staff usually thinks the problem has been solved and gets off the phone. They said on the last call they added me to a list where they will email with a fix if I am a part of a specific problem, however I cannot fully rely on freedompop returning my email as I have waited a while on support emails as well.

It looks like I get bars of signal for phone service, and I know I am in a 4g LTE area because the netgear mingle I have runs on 4g perfectly right next to the phone. But still not 4g or even 3g on the phone, NO DATA ACCESS AT ALL.

I have tried updating the messenger app, the freedompop app. I have tried PRL and profile updates and even a carrier reset before these.

Please let me know how I can fix this phone as I do need it for work!? I hope this forum post is heard.

Have a good day all,
Cam

Answers

  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    Hello @Cameron Jenkins

    Have you double check to make sure that the Mobile data is enable on the device? Open up settings>>Find Data usage and open, make sure that it is check at the top.

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

  • Cameron JenkinsCameron Jenkins Posts: 32FreedomPop Newbie
    An update... I called support just before they closed and confirmed again that this case is indeed escalated. They told me to wait 5to6 hours before a fix is possible.

    Hope I can get this fixed soon!
  • Cameron JenkinsCameron Jenkins Posts: 32FreedomPop Newbie
    And also just to update yes I have enabled mobile data, im in a 4g area just checked the map. Still no data. Admins help please
  • Rebecca S ODellRebecca S ODell Posts: 1FreedomPop Newbie
    I am having this problem, too! I just got my phone 2 days ago and have not been able to receive calls into it...nor can I send calls out! I checked to make sure the "Mobile Data" box is checked on my phone...and it is! Please advise!
  • Cameron JenkinsCameron Jenkins Posts: 32FreedomPop Newbie
    I have tried the post above. Cdma did not work for me sadly... see below.

    http://imgur.com/RXcbJzX
    Netgear mingle above, blazing fast 4g I wish my kyocera would get

    Still cannot get a connection to either 3g or 4g on my kyocera hydro even though the mingle in the picture above get 4g lte just fine in the same area as my phone. It must be the sprint network totally blocking me or perhaps my phone needs a special update in order to connect to 4g. Even with cdma only or adding LTE I only get error messages (or network busy) when I try a PRL update or profile. And if the carrier reset does work sometimes and I get 3g for a second it will never load the messaging app or even a simple website. Sucks going on nearly a week of zero data connection capability even though my netgear mingle is amazing and gets blazing fast 4g anywhere I go, the phone is in range of this same mobile network, it`s just a matter of getting it to connect.

    PROBLEM: I have tried enabling mobile data, PRL update, profile update, carrier reset, switching to CDMA only, and none of this has given me access to mobile data to make a call/txt or even go to a simple website.

    Please help!
  • Rich Sias (16th)Rich Sias (16th) Posts: 3,124FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    There has been odd outages on the Sprint network that would let some devices work ok and others not. Some whole cities lost most devices and others only a few if any.
    @Cameron Jenkins your ticket you created I will forward to Freedompop to handle the friend invite that should have worked out for you. They are probably covered up in lots of requests due to this strange outage since Wed Mar 9. Be patient they should get to you by a couple of days after the outage issue gets fully fixed enough.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • Cameron JenkinsCameron Jenkins Posts: 32FreedomPop Newbie
    edited March 2016 #9
    Thanks for the reply rich! I hope to see these outages fixed soon as I would like to use my phone. and thanks for forwarding that as I did work hard to convince that person to buy Freedom pop services during this troubling time lol

    Hopefully the next update I post will be a success story

    EDIT: March 16th @ ~2pm: Still no luck with mobile data, I see the announcement at the top of the forums, hope to hear some kind of response soon :(
    Post edited by Cameron Jenkins on
Sign In or Register to comment.