**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

another mifi 4082 that can't access internet

i ran out of data and upgraded my plan only to find out the plan i choose was 4g only so support refunded my money and changed my plan back to what i had orignaly which is the pro 500mb 4g/3g and gave me some data for free. I did what support asked and was told that now i should be able to get online. I can get to the mifi landing page but if i try to go to any website i am directed to the freedom pop page saying i don't have 3g activated on my device or im not signed up for a 3g plan both of which are false my account shows that i am enrolled in pro 500mb 3g/4g monthly and i have changed the wwan settings to both 3g only and 3g prefered i have trying resetting mifi updating both prl and profile but every time i have tried to update either i get please wait while we check for updates this could take up to 5 minutes i have left it alone for up 30 minutes yet it still says same thing i have tried numerous times both connecting via wifi to mifi and by usb to mifi. i have also tried connecting mifi via usb to computer and using a diffrent internet connection and still won't work ive done a hard reset tried forgetting network everything i have read in the forum but nothing has worked. when i turn on wifi light goes from amber to soild green once i connect to it it goes to flashing green landing page is showing full bars and full battery charger help please
Sign In or Register to comment.