**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Please help - no data on iPhone 4S since iOS 9.3 update...

Jerry KuhnJerry Kuhn Posts: 1FreedomPop Newbie
Could someone PLEASE help me resolve this issue. I registered my old iPhone 4S a while back and EVERYTHING was working great until I recently updated the iOS to 9.3. Now it does not receive data over 3G. The upper left hand corner shows full bars and Spring 3G, however it is NOT receiving data over 3G. I can only place call using wifi. Then I try to use Safari under 3G, it does to freedom.selfservicesetup.com. When I try to use the caller/messaging Freedompop application (newest version), it continuously tries to "register", and "retrying", over and over. Everything worked perfectly up until upgrading iOS to 9.3 recently. I have tried to do a ##update# and ##clear# about a million times. I have tried to reset network settings over and over. I have even tried to wipe the phone completely and start from scratch. Nothing will get data working again. The website shows that I have 850 MB available, of which I've only used about 23MB, so its not an issue of no data available. PLEASE, could someone help me get this working again. Thanks!

Comments

Sign In or Register to comment.