**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Can't access network - please help

Ken  RichKen Rich FreedomPop Newbie Posts: 12
I only use my cell phone while traveling and make about 10 calls a YEAR(!) So I don't fool with it much. It's rooted and running Exodus, but that hasn't been a problem in the past. When I first got it, it worked fine. Now it only works on wifi. When wifi is turned off, it only get a message that there is not network connection. I've installed and selected the FP messaging app but it doesn't make any difference.

I even factory cleared the phone and reset it. (still Exodus which worked before). I still get the same message. What do I do now?
Sign In or Register to comment.