**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Kyocera lost activation and I can't reactivate it

David HansonDavid Hanson FreedomPop Newbie Posts: 1
edited May 2016 in Kyocera Hydro Icon #1
I bought a Kyocera Hydro Icon from Freedompop in November 2016 - after some initial problems getting the phone to work, it worked find until 3 weeks ago when it lost the ability to connect the cellular network. I made a service request and one week later a gentleman started making suggestions. Everything that he has suggested for the last 2 weeks has not worked. He had me reinstalling Freedompop Messaging App, update PRL (the phone won't update PRL and it won't update Profile either).
I have tried factory resets 4 times so far - once at his request. Today, he asked me to "sync account data" in the Freedompop messaging app which didn't help either.

I have also tried ##72786# as the Freedompop diagnostic app suggests. The "handsfree activation" simply times out after attempting to activate 5 times. According to Sprint's map and verified by the Freedompop support person Sprint has an adequate signal here. Our family's other Freedompop phone, a Moto E, works fine here. And as mentioned the Kyocera worked fine for 5+ months.

At one point, he had me send information using the Freedompop Diagnostic App. He told me that there was a very good cellular signal according to that information.

I get the feeling the support person is leading me down a diagnostic script rabbit trail but I don't know enough about cellular activation to be sure. I don't think that we are following a logical path to the root cause. In my thinking, either there is a hardware failure in the phone and we should just give up OR the problem is caused

Any suggestions at getting this problem fixed or at least determine that there is a hardware problem where it is not fixable?

My suspicion is that the Sprint network is not letting my phone activate due to an administrative issue. But since the support person more or less ignores what I write in deference to the "official" diagnostic script that I presume that he is required to follow - I don't believe that an administration issue with Sprint has been considered. The activation failure occurs after a factory reset so why would fiddling with the Freedompop messaging app as I have been instructed to do help?

David
Post edited by David Hanson on

Comments

  • SoWatt2000SoWatt2000 FreedomPop Newbie Posts: 1
    I seem to have similar issue, but for me the phone never worked, received mid April... I'm slowly exchanging email with their support. First thing they asked me to do was to download the messaging app. It was already installed on the phone. I made sure to update it but still no luck ;-( I send them screenshots of everything I see on the phone...
Sign In or Register to comment.