**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Nexus 5x no data connectivity

Kristina MarkovicKristina Markovic Posts: 51FreedomPop Newbie
Hi all, I recently called to activate a Nexus 5x on freedompop and was told it was successful. I downloaded the messenger app and all the information shows up correctly the phone number account and everything the problem is I get no service outside of WiFi. I am certain I bought the correct sim card and even called tech support they did some sort of reactivation or whatever and said to wait a couple hours and it should connect to the service after power cycling the device.

So I have done this and nothing has changed. When I turn wifi off I get nothing no service. I cant even use the freedompop app because it says no service immediately upon opening the app. I have tried the usual trouble shooting tips as recommended by tech support ##72786# or *#*#72786#*#* nothing worked. The phone says no service. When I do an initial start up of the phone it says searching for service and briefly where it shows data connectivity it says Sprint but eventually i get a pop up message that the sim card is locked and to power cycle device. After that I have no signal it says no signal and in the to left corner of the screen it says no sim.

I do find it interesting, and am wondering if this might be the issue, that I was never asked about my ICCID (sim card number) when I activated this device. Alternately, when I initially activated my previous BYOD device I was asked for the ICCID number and got service right away. I have also tried using the phone with no sim card inserted at all and still no service. No bars and says no service same like with the card and tried all troubleshooting that way as well. No dice.

Tech support verified on the last call that my IMEI is correctly set up in their system so its not a matter of the wrong device and all information is correct I just never asked about ICCID during the call as this was something I thought of after their troubleshooting wait period didn't work.

A few points to save time if anyone can help me

I am certain data connectivity is turned on on my device.
I am certain I am in a good service area (my home as i have another FP device that works swimmingly on data only no wifi to attest to the good network signal full bars 4G LTE)
I have tried network reset to no avail as well as above mentioned ## codes along with ##34963# none helped
Rebooted device multiple times
Uninstalled and reinstalled app
Tired PRL update but phone automatically says no PRL update available
Tried Profile update but nothing happens phone just circles saying searching and does nothing have let it sit over 30 min plugged in to make sure I don't lose battery and nothing comes of it I have to just back out as it doesn't give an answer of being successfully or failed.
I have tried it with or with out a sim card inserted
I have bought a brand new sim SIMGLW446C to see if it was a bad sim card and the same problem persists
This is a BYOD Nexus 5X that I purchased brand new through GOOGLE so any holds on the account or IMEI or MEID being blacklisted are impossible.
I have called tech support and verified all my account info is correct and matches their records (aside from ICCID since I just thought of this) the rest matches IMEI, email, phone number shows up on messenger app and opens to correct account.
Finally I have performed, the much dreaded, factory reset of the device and still no connectivity outside of WIFI in fact it remained on the "activating cellular services...may take up to 5 minutes" screen for at least 30 minutes until i got fed up and tapped skip to be able to at least use my device in some way.

Please any help is greatly appreciated as I have no service outside of WIFI range for over a week which isn't ideal since god forbid something happens on the road I'm basically **** and stranded.

I feel it to be a SIM issue that the ICCID isn't set up in my account correctly or at all for that matter but I could be wrong. All I know is that this device was on the approved list and I purchased it direct from Google and expected it to work without a hitch since others have been able to activate it as well.

@LarryS helped me with which sim card to purchase as well after he was able to successfully activate his Nexus 5x. (sorry to throw you into the mix but if you have any other pointers I am all ears!)

Many thanks for your time and I look forward to hearing some helpful information from you all. :)

Comments

  • thomasjph1thomasjph1 Posts: 3FreedomPop Newbie
    Hi, did you get this resolved? I'm having the same problem with my 5x
  • Beth HBeth H Posts: 3FreedomPop Newbie
    Hi, having the same problem with my Nexus 5. Anyone come up with a solution?
  • FruGuruFruGuru Posts: 19FreedomPop Newbie
    Test the phone with other known working SIM?
  • Kristina MarkovicKristina Markovic Posts: 51FreedomPop Newbie
    Hi all I am sorry I haven't logged on in a while but I was able to figured it out. It was the SIM card. I had to put a call into tech support for them to update the ICCID# of the SIM and after they did it worked perfectly.
  • Rich Sias (16th)Rich Sias (16th) Posts: 3,124FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    Great news to hear ! Nice to hear of resolutions even if much later. Only way all of us can learn how to take care of what we have now.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • Catherine LeeCatherine Lee Posts: 1FreedomPop Newbie
    My phone with Freedompop account started having a problem to where I was not able to use it any more. I have purchased a Nexus 5x and signed up another account so that I can swap the account later.

    I was able to establish an account with my nexus 5x but data connection was a problem. I noticed that when I restored my google account on my new phone it restored Freedompop Messaging App as well and it had my previous account information. I uninstalled and reinstalled the Messaging app and it is now showing the correct new account and the phone number. Curiously, It show a SMS message from Freedompop which says "Your phone number change request has been completed! Your device configuration will now be updated" For the record, I have not requested a change of phone number.
    Every reboot is followed by SprintDM configuring which ends with leaving me with no data connection. I have tried the reset procedure which did not help either. I have filled out a ticket also on this problem.
    If anyone could look into my account I would really appreciate it. My goal is to get this new account working and swap the account with my old account which in unusable due to the damaged phone. Thank you in advance. Catherine,
  • [Deleted User][Deleted User] Posts: 0 admin
    The user and all related content has been deleted.
This discussion has been closed.