**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

The Incoming Premium Voice setting/checkbox is enabled. Unable to receive calls with data/wifi off.

This morning I activated the Premium Voice on my phone and I am not able to receive incoming calls when wifi and cellular data is turned off. Outgoing calls work as promised, but incoming calls don't, even though the setting for Incoming Premium Voice calls is turned on. I have already reset my network settings and did a PRL update. I need reliable incoming calls, otherwise I do not need Premium Voice service. Please help! I've also submitted this question on the site: Question Reference # 160511-000167

Thanks,
Albert

Comments

  • Marc JosephMarc Joseph Posts: 172FreedomPop Newbie
    Currently, premium voice only works for outgoing calls. Why the setting for enabling PV for incoming calls is there is a mystery, unless FreedomPop plans on offering this service sometime soon.
  • Albert (ResetDay: 4th) SzetoAlbert (ResetDay: 4th) Szeto Posts: 3FreedomPop Newbie
    so I should just deactivate the Premium voice service until there is confirmed(from other users), that incoming calls work?
  • Leota DismangLeota Dismang Posts: 1FreedomPop Newbie
    I am having the same problem.Ever since I updated premium voice I have not been able to receive calls..I can make them though.How do I disable it? or deactivate it?
  • Carol LewCarol Lew Posts: 63FreedomPop Newbie, FreedomPop Expert
    @Albert (ResetDay: 4th) Szeto and @Leota Dismang, you can try changing the incoming calls to non-premium. In the Messaging app, go to the Menu -> Settings -> Incoming Call Preference and select "FreedomPop Application." The description for this option is somewhat strange: "Select this option if you are using FreedomPop account on different devices."
    ~~~ Owns a few High Tech Computers while wearing / running a Red Hat Fedora ~~~
    Devices: HTC Evo 4G, HTC Evo 4G LTE, and other HTC devices (not under FP), MiFi 500 LTE
  • Albert (ResetDay: 4th) SzetoAlbert (ResetDay: 4th) Szeto Posts: 3FreedomPop Newbie
    http://puu.sh/oTIkb/c178feb4b8.png The reason I signed up for Premium voice is specifically so that I CAN receive calls to my freedompop number while in a low signal/no data/3g/lte area. I signed up for it after seeing the Setting page with that checkbox, indicating that it should receive incoming calls. It has not been working.
  • Lei TangLei Tang Posts: 22FreedomPop Newbie
    It doesn't work for mine either. But I know it could work as I saw it worked on some phones.
Sign In or Register to comment.