Samsung S4 (BYOD) will not activate after Carrier Reset

Lalit MathurLalit Mathur Posts: 10FreedomPop Newbie
I have a Samsung Galaxy S4 that I had been using with FreedomPop for a few months now. I got an email about doing a carrier reset to help improve connections, so I did that. Ever since, I am not able to call/connect to data when not on WiFi. I have the latest version of the FP apps and everything works fin on WiFi, but when I don't have WiFi, the phone is not able to get a data connection at all and so nothing works. The Activation process seems to error out immediately, it retries 5 times, then leads to a screen "Self-Service" that 's blank with a "Done" button, but no data connection at all. I have tried to Update Profile and Update PRL, but both just lead back to the activation screens with the same results as before. I have tried to play around with the mobile data options, to no effect. Any suggestions on what I can do to fix this? It's getting to be about a month with no data now :-(

Comments

  • willmott3willmott3 Posts: 2FreedomPop Newbie
    Hey i ran into this problem exactly few days back ... after trying very hard i found 1 solution which worked for me , hopefully it can too for you.

    pull down the notification bar , click and hold the process of activation then you will see a " i " on the right side click that once. a new windows will open with the process details , let it " compute" for few seconds then kill the task and then clear the cache and clear the data by pushing those buttons , you will see it once you are there.

    hope it works for you....let me know thanks.
  • olivianoodlesliolivianoodlesli Posts: 1FreedomPop Newbie
    Hi,
    I am having exact same problem as Lalit Mathur also with a Samsung S4 phone. I tried what willmott3 suggested as best as I can understand but it doesn't work. The Self Service error at end is a message saying that "reseller Partner Id not allowed for activation" with Done and Exit buttons. Have you resolved your problem?
  • freedom0188freedom0188 Posts: 2FreedomPop Newbie
    I know this is almost one year old message, but I am having the same problem. Any solution ?
    I have S4, just start the freedompop service, not able to activate my phone.
Sign In or Register to comment.