**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Newly activated S4 no mobile data connection

David CoutureDavid Couture Posts: 11FreedomPop Newbie
Hello all,

I just activated an S4 with FreedomPop and I am not able to make or receive calls, texts, or use internet-related services without wifi. Also, I cannot install the FreedomPop Messaging app; I get an error -505. When I disable wifi to try and force a mobile data connection I get an error message saying, "unable to establish a wireless data connection MIP: 67".

About a year ago I had an LG G2 activated with FP and it asked me to do something called (I think it was) a PRL update to get everything working. Is that needed with this phone as well?

My apologies if I should have tried to do a PRL update and/or carrier reset before posting here; I just don't want to irreparably mess something up.

One more thing; can someone link to the admins in a post, I haven't memorized their usernames yet.

Comments

  • David CoutureDavid Couture Posts: 11FreedomPop Newbie
    I managed to get mobile data, calling, and texting to work, but I am still having problems installing the FreedomPop Messaging app. I still get error 505 when trying to install it.
Sign In or Register to comment.