Can't receive calls, can only make them.

BryanGBryanG Posts: 1FreedomPop Newbie
This has been trouble from the start. I took the phone out of the package, turned it on, made a call, and it worked. Next I took my wife's phone and tried to call my freedompop phone, and nope, won't receive calls. I waited a few minutes and tried to make another phone call and not that doesn't work, so now I can't even make a call, it tells me I need to activate it, but when I go online, I'm told it is activated....
So I try again and nothing, I couldn't get it to make or receive calls. Went through all the settings, everything looked good, and should be because I didn't change any of them. So the whole thing stops working. I decided to do a factory reset and start over.
Now, after the factory reset, I can make calls, but I can't get them.
So,
I call tech support, and after being on hold for almost 2 hours (I watched a whole movie while on hold) I had to hang up and get on with life.

I'm not upset that it's not working, I expect bugs/problems when starting something new, what does upset me is that I can't get help.
I hope I can get some help here, but I don't think the help I need can be done on here on the forums...
Sign In or Register to comment.