**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

BLU Studio X - missing incoming calls

David SingletonDavid Singleton Posts: 36FreedomPop Newbie
I have the BLU studio X, with the Global Sim Kit. Outgoing calls work perfectly, web works fantastic, but I have two issues. #1 incoming calls work about 50% of the time, does not matter if I am on wifi or 3g. #2 I get a roaming pop-up when I attempt to make a call "the card you are using is roaming, would you like to continue" I see no way to turn that off, running android 5.02.

Thanks to anyone who has any ideas on solving these - this service would be fantastic if I could resolve them.

Comments

  • Brian BartonBrian Barton Posts: 180FreedomPop Newbie
    I've never used that version of android but isn't there a option to just allow all roaming?(it needs to) the card will roam on two networks in the us depending on the coverage and wireless bands in the area between t-mobile and at&t. where I'm at I've mostly been on at&t without much switching but it could be that your phones antenna is just not very good.
  • David SingletonDavid Singleton Posts: 36FreedomPop Newbie
    yes it has the roaming option, and I have the roaming option turned on, however there is no option to ignore roaming warnings. I did uninstall the app, and re-install it, the calls seem to be coming to the phone better, but I still can not get rid of the roaming warning when I place a call.
  • Brian BartonBrian Barton Posts: 180FreedomPop Newbie
    edited June 2016 #4
    is there a thing called roaming guard in the mobile options? is it possible to turn it off? Settings/More Settings//Roaming/Roaming Guard and uncheck the box. I believe that will fix it. only maybe though cause Blu phones antenna are very very bad. also did you select a network operator? (in network settings)
  • David SingletonDavid Singleton Posts: 36FreedomPop Newbie
    no such setting, I have not had any antenna issues, in fact this usually has better signal than my Verizon S7 (work phone) When I go to network operators I see Freedompop 3g twice, I can choose either one or I can set it to choose automatically and the same thing happens,
  • Brian BartonBrian Barton Posts: 180FreedomPop Newbie
    hmm most likely one of the operators is at&t while the other is t-mobile. that's weird they don't have different names. select one then try a call with each operator. also your not trying to make the call with the native dialer are you? your using the fp calling and texting application?
  • David SingletonDavid Singleton Posts: 36FreedomPop Newbie
    I am using the FP messenger, but it brings up the native dialer on it's own.
  • Brian BartonBrian Barton Posts: 180FreedomPop Newbie
    edited June 2016 #8
    is the fp messaging app set as default? also I looked at a few forum posts and it seems a couple people have this problem with a different brand/model. also set it to 3g only.
    if none of that helps maybe this link will help? http://forum.xda-developers.com/showthread.php?t=2581301
  • David SingletonDavid Singleton Posts: 36FreedomPop Newbie
    Thanks for trying
  • Brian BartonBrian Barton Posts: 180FreedomPop Newbie
    sorry I wasn't much help :/
Sign In or Register to comment.