**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Unable to activate Nexus 5, email already in use

Gregory LerchGregory Lerch Posts: 4FreedomPop Newbie
I sent an email to freedom pop through the MyFreedomPop app about this 4 days ago but haven't heard back. Thought I'd try to fix this on the forums.

I bought my Nexus 5 from freedompop.com and it came in two days. However, the device wasn't activated. When I tried to activate it, it said my email was already in use. Also, the auto fill ICCID did not match the ICCID or IMEI on my packaging. I tried entering the correct ICCID but it still said my email is already in use. I have also tried updating and reinstalling freedompop messenger but that didn't work either.

Is there an admin that could help me with this? I believe that the ICCID isn't correct in freedompop's database.

@Jorge M. @Ali @njfulwider5 @scott @Florencia @Jon J. @Lucy

Thank you.

Comments

  • svordysvordy Posts: 1FreedomPop Newbie
    I am having this exact problem. I got my phone today from FreedomPop, and it says that it should be activated, but when I try to make a call it asks for me to activate the phone, then tells me that I can't because the email is already in use.
  • Gregory LerchGregory Lerch Posts: 4FreedomPop Newbie
    We are definitely going to need admin help on this one.

    @Jorge M. @Ali @FreedomPop @njfulwider5 @scott @Jon J. @Florencia
  • Gregory LerchGregory Lerch Posts: 4FreedomPop Newbie
    Well Freedom pop just replied to my email, so I guess we will have to wait and see what happens.
  • shinra07shinra07 Posts: 1FreedomPop Newbie
    I'm having the same problem, also with a Nexus 5. It arrived 7/15/2016 and I haven't been able to activate it, it's slowly moved from kitting to ready to ship, but seems to be stuck there. I e-mailed FreedomPop the day i got it and they said it would be answered in 48-72 hours but no response. It's really frustrating not having a phone.
  • Jenny WJenny W Posts: 13FreedomPop Newbie
    I have the same issue as well. I can't activate the phone.
  • Gregory LerchGregory Lerch Posts: 4FreedomPop Newbie
    Well after sending my phone's specs back to Freedom pop, they resolved my problem.
  • IshiyaKazuoN5IshiyaKazuoN5 Posts: 5FreedomPop Newbie
    How did you e-mail FreedomPop? I tried [email protected] (the address provided in the booklet that came with the phone) and I got an auto-response that the address is not being monitored and I will not receive a response.
Sign In or Register to comment.