**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Hello, I bought a global sim card and I can't activate it.

Aparecida LimaAparecida Lima Posts: 1FreedomPop Newbie
My phone is a Samsung galaxy S5 unlocked.
I made exactly what they said in the packet, but I got a message saying that "oops that's an error trying to communicate with the server.Please try again later."

There's no problem with the phone, because I already tested with another freedompop sim card and works fine.

Somebody can help to solve this issue?

Thanks

Answers

  • trackballtrackball Posts: 1,585FreedomPop Newbie ✭✭✭✭✭
    Maybe it's your sim card. Did you borrow the other one from someone else or do you have 2 sims ?
    I guess you tried your first sim in the other phone and it worked and it just doesn't work in your S5 ?

    This is only a troubleshooting test.
    Put the working sim in the S5 and then open settings and find FP app, open that and check or verify the ph# for the 2nd sim card. Try the same with the 1st card that doesn't works in the S5, see if you can verify the ph# too. If you still get a 'oops' message, then you know the sim is defected.

    If there is a 2nd phone with the 2nd card that works in both phones, do the same steps to see if you can isolate or narrow the problem to the 1st sim card

    Also are you using the same email and password for the two sims or are you changing the login that goes with each card?
Sign In or Register to comment.