**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

Solved: Can't register my sim card on my phone.

Antonio GutierrezAntonio Gutierrez Posts: 1FreedomPop Newbie
edited July 2016 in Global SIM Card #1
Hello, I'm new so please bear with me if this problem has come up before. I'm trying to see if this service is a viable option for my father who is not a heavy phone user, but needs something he can use for emergencies and the like.

-I just received my Global GSM sim kit and inserted it into an old T-Mobile P-509 I stopped using about a year ago.
-I downloaded the FreedomPop Messaging app, but when I started it up, it notified me that it was "Unable to recognize SIM" and to make sure I inserted it properly (which I did, twice).
-I tapped the Manual Config button and filled out the phone#/password.
-I get a notification that says "Registering for Push Notifications"...then it just stays stuck in a blue loading screen with the same notification in the notification panel.

I'm wondering if this has something to do with the phone previously being used with a T-Mo sim. Was I supposed to do something before inserting the sim? I also tried adding the APN name per the instructions but it won't let me save it without having an MCC# which I can't find anywhere.

I would appreciate any/all help I can get with this, and apologize again in advance if this has been brought up before. I had hard time navigating these forums.

Edit: I feel so dumb. I didn't realize I had answered my own question in this post. The phone is SIM-locked to T-Mobile, so I have to unlock it first. I'm now in the process of receiving my unlock code, so hopefully this is the only obstacle that was preventing the Messaging app from registering the device.

Edit2: Also, I realized this only a couple hours after posting this, but kept forgetting to add an update.

Edit3: After installing Google Play Services, and freeing up enough space, I was able to get the phone registered with my number. Installed the app, loaded it up, and in less than a minute, I was in the app's home screen.

PS: I can't figure out how to close/delete this question, so if a forum Mod could please take care of this I would appreciate it, thanks!
Post edited by Antonio Gutierrez on
Sign In or Register to comment.