Blu R1 HD Dual SIM + hotspot connection (FIXED with WorkAround)

Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
edited July 2016 in Using Your Devices #1
Hi, I just got BLU R1 HD 2G version with Amazon Ad version for $59.99, with using freedompop SIM, I was able to get Data from both SIM 1 and SIM 2
however, when I enable Hotspot feature , which should allow Freedompop SIM on BLU R1 HD shares data to other WIFI devices, However, my Hotspot client able to pick up IP address, but just can't connect to any website from hotspot client . I did try both SIM 1 and SIM 2 , same issue, I also try no password for Hotspot, same issue,

I Tested Blu Studio C HD and Blu R1HD phones, Both phone failed to share as freedompop as WIFI hotspot , I wonder if Freedompop block this?? or because of Roaming data can be use as Hotspot?? Please advise,

PS: while I am sharing Internet connection via Hotspot , internet connection from BLU R1 HD was good.

If anyone read this post and you are using BLU R1 HD, please help if you can share data with T-mobile or AT&T SIM, as far as I can tell, I can't share data with Freedompop, ( wonder if this is ROAMING issue??) or Freedompop block it??

PS: I do have an old unlocked international version of Samsung S2, using Freedompop SIM with hotspot on S2 has no issue sharing internet from freedompop to my other android device. Please help anyone, thanks

Do I need to sign up for "FreedomPop WiFi Hotspot service" or "Freedompop Prime service" ?? in order to get Hotspot works on Blu R1 HD, I hope this is Freedompop limitation , but not BLU limitation.
Post edited by Blu R1 HD User on


  • JJFreedomJJFreedom Posts: 296FreedomPop Newbie, FreedomPop Expert ✭✭✭
    edited July 2016 #2
    It seems your APN settings are incorrect.
    Make sure you fill out the information exactly like so:
    • Name: FREEDOMPOP [This is optional, you can really put anything here]
    • APN:
    • APN Type: default and dun
    • MCC: 234
    • MNC: 20
    • IP Protocol: IPv4
    • APN roaming protocol: IPv4
    • Bearer: Unspecified
    • MVNO type: none

      leave everything else blank
    When you set up all the information correctly, you should also see an "R" next to the data signal in the notification bar. This mean's it's "roaming" which is necessary for the service.
    I usually respond within 24 hours. If you need help, feel free to ask.

    Also, to tag me directly, write @JJFreedom. - this way I will know when you are talking to me.
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Hi, JJFreedom I confirmed that BLU R1 HD has no issue with Tethering with T-Mobile TOGO SIM card , actually, this phone report 4G when I enable T-mobile TOGO data plan, and I enabled tethering, , use another phone to connect to T-mobile website, which is fine, ( since I did not pay for data, I can only verify by go t-mobile website)
    This concluded that BLU R1 HD ( phone itself has no issue with Tethering (hotspot), so JJFreedom, I shall try to your provided APN setting on BLU R1 HD, please stay tune.
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Hi JJFreedom, Your additional APN setting works for my BLU R1 HD. Thanks, Now, I can enable HotSpot ( tethering) with freedompop on SIM 2 , while using other carrier for 2G Voice plan in SIM 1

    PS: As others BLU R1 user mentioned, this BLU R1 HD Phone need to power cycle if switching Data Plan from different SIM slots . In case I do not reboot the OS, Freedompop only report 2G speed even after those setting.
    Again, this is not a BLU R1 HD review forum, so I only mention how to get BLU R1 HD works with Freedompop.

    Now I have usable Duel SIM solution for Data Plan while I can keep my own 2G Voice Plan, thanks for support.

    One of my friend who did not use this forum , he was about to return his BLU Studio C HD, but I guess we can keep BLU, and I hope BLU can be listed as support DUAL SIM phone

    Thanks again!! JJFreedom!!

    In case I found any solution, issue related to Freedompop with R1 HD, I shall add more post here.

    PS: In case you have issue saving Freedompop APN, most likely due to your others SIM has Data plan enabled, so you must disable data plan from other SIM, re-enable Freedomop data Plan and REBOOT your phone.

    PS: Since I do not have Amazon Prime Account, I ask my friend to order 1 for me.
    Interesting that you can SKIP all AMAZON account during phone initial setup, BUT DO NOT PUT your FREEDOMPOP SIM card in yet, because a New Firmware just released , you may want to update the Phone Firmware using WIFI, have google account setup , update before trying FREEDOMPOP SIM.

    Here is my R1 HD info ( after OTA Android update via WIFI)

    Android Security Patches: June 1 2016

    Kernel Version: 3.18.19+ SUN Jul 10 00:22:22 CST 2016

    BaseBand version :MOLY.LR9.W1444.MD.LWTG.MP.V79.P14 2016/06/15 17:12

    Build Number: MRA58K

    Custom Build Version: BLU_R0010UU_V6.4_GENERIC 10-07-2016 00:10
  • JJFreedomJJFreedom Posts: 296FreedomPop Newbie, FreedomPop Expert ✭✭✭
    My Blu R1 HD doesn't require reboot. It just takes 30 seconds after I hit the switch. Sometimes, you do have to go to the data usage panel in order to do it.

    The compatibility list is for those attempting to BYOD (Bring your own device) under the CDMA service (running under sprint, not GSM). All unlocked 4G Android 4.0+ devices and iOS 7.0+ devices are to be assumed as a compatible device with FreedomPop. Since Blu R1 HD works under these requirement, one is to assume it's compatible.
    I usually respond within 24 hours. If you need help, feel free to ask.

    Also, to tag me directly, write @JJFreedom. - this way I will know when you are talking to me.
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Hi, JJFreedom, I need your help ,

    My friend using BLU Studio C HD, which is also a Dual SIM Android Phone, He still having my original issue about no connection with hotspot client, Do you know if he need different APN setting??
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Hi, All
    I am using Free basic data plan , which is not suppose to have Tethering service unless we subscribe the FreedomPop Premier . However, I was 1 time able to get Hotspot working with mutli PC and Android device
    Before I disclose the trick.
    Does anyone has a clue if I am trying to workaroundFreedomPop Premier tethering service. If so, I wont follow up this task. Thanks

    Please reply. Thanks
  • JJFreedomJJFreedom Posts: 296FreedomPop Newbie, FreedomPop Expert ✭✭✭
    @Blu R1 HD User - Your friend will need to enter the APN details exactly how I wrote it in an earlier comment (including the "dun")

    If it still doesn't work properly, you will most likely need tethering service.
    I usually respond within 24 hours. If you need help, feel free to ask.

    Also, to tag me directly, write @JJFreedom. - this way I will know when you are talking to me.
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Hi, JJFreedom, Thanks for info.

    I actually able to get Freedompop running with HSPA+ using your setting on my BLU R1 HD

    Since this phone only show 4G icon when 4G connected, but will not show if you are using Edge, HSPA or HSPA+ (AKA HSPAP) , so I am using the following service menu to check what kind of connection speed I am getting from freedompop

    *#*#4636#*#* – Display's Phone information, usage statistics and battery.

    anyway, since I also want to use freedompop phone, which mean I have to put freedompop SIM card in slot 1

    so, I did and Freedompop phone service works great with hotspot.
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    edited July 2016 #10
    Hi All,

    I think I found a crazy way to create a hybrid Freedompop Hotspot Service with Dual SIM Phone , First , JJFreedom:Thanks for your information about APN setting, plus other BLU R1 User provides Android Network tools for me to troubleshoot this issue.

    Here is the Hardware and Software requirement to get the Hotspot working with Dual SIM.

    In order to get the Hotspot working with freedompop, your phone need to create a mix data profile , by first enable 4G from T-mobile , follow by switches to Freedompop Data plan on the fly.


    A. DUAL SIM phone with Hotspot feature ( currently I am using Blu R1 HD) ( No need to root the phone)
    B. 2 SIM card, Freedompop SIM card , T-mobile pay as you go voice plan only ( No need to subscribe any Data Plan)
    C. Optional : Windows or Mac or linux OS that you can use for "ping, nslookup or tracaert"

    Software: optional
    On BLU R1: Network signal Information on Android ( free /ad version), this is optional and just for Troubleshooting only
    On BLU R1 HD , use dial pad to bring up service menu with *#*#4636#*#* , this is also optional, use for troubleshooting.

    1. Make sure APN: ; APN Type: default and dun ; MCC: 234 ; MNC: 20

    2. Keep ROAMING ON and use proper APN for Freedompop SIM

    3. Turn off hotspot, turn off all Dataplan for both SIM,

    4. Go to Dual SIM setting, turn off both SIM card at first , enable T-mobile SIM card only.

    5. Set T-Mobile as preferred Cellular Data in setting->SIM Card

    6. Enable Data plan on T-mobile ( Make sure it show 4G at top ). ( wait for 30 second, or use Android tools to monitor the data service carrier update) If it show E or 3G icon for T-Mobile network , you need to update T-Mobile preferred Network Type to "2g/3G/4G LTE" , if still not showing 4G , you will need to power off the phone and swap T-Mobile SIM , Freedompop SIM slots.

    7. Now, time to switch Data plan carrier , Do NOT TURN OFF data plan on T-mobile, In stead , go to BLU R1 ->setting -> data usage , go to freedom Tab, and select enable "Cellular Data". This single action will also update preferred data plan to Freedom pop as well.

    8. Go to Dual SIM setting, Enable Freedompop SIM card at this time.

    9. Make sure Freedompop SIM Roaming is ON
    ( this action will create a hybrid/MIXED APN service )

    After step 9, "Network signal Information" will report ( Data service= Unknown, also report data plan: Connected

    "Network signal Information will report APN using MCC: 234 ; MNC: 20.

    10. If still not able to connect to Internet from Hotspot client , use your Android phone that contains freedompop sim, try to go to Google play or anything to check if Freedompop service able to connect to Internet.( make sure this step is ok before move to next step, you may need to make sure the APN setting is correct, you may also need to update preferred Data Plan and re enable data roaming for Freedompop.

    11. On Android . launch "Network signal Information", you will see unknown data plan service. make sure MCC report 234 and MNC reports 20

    12. By now, if your hotspot client still not getting data from Hotspot , you must did something wrong. since I need to try few time to get this works. Some time , I need to switch T-mobile and Freedompop SIM card from SIM 1 to SIM 2 slot in order to re-validate this instruction.

    13. ADD ON: Update: This solution DOES NOT requires to have Freedompop in SIM 2, Tested that Freedompop can be in SIM 1 or SIM 2 ( with hotspot enabled) , but it is better to place Freedompop in SIM 1 in order to get Freedompop Messaging app launch and run smoothly.

    NOTE: This solution will works even after ( power off your phone, reboot your phone, enable , disable hotspot)
    This hybrid hotspot profile seem to keep in Android OS until you swap out SIM card. Since everytime a new SIM added , this hybrid SIM profile need to rebuild. Which mean you will need to redo all steps in order to get the Hotspot working with freedompop data plan.

    Anyware, A working Hybrid profile should display the following information when view from " Network Signal Info" Android App

    Net Operator: T-Mobile/Hutchison 3G UK (Display order is not base on slot location)
    SIM Operator: T-Mobile
    Net Type: Unknown
    Net Strenght -91 dbm * 11 ASU
    Data State: Data connected
    Data Activity: upload+download activity
    MNC: 20
    Country code US
    IP :
    External IP: 193.240.57.x ( when I lookup IP address on web it returns Organization: Fogg Mobile - UK)
    Roaming: Roaming is OFF
    Phone type: GSM

    NOTE: I also did power off, swapped out and put in an invalid SIM card, It still works as long as don't re config SIM profile. ( This is still unclear to me that some time the phone detect New SIM inserted, but sometime adding an invalid/ no service SIM card won't ask for SIM reconfiguration ?? )

    I did put in an invalid/inactive SIM card, replacing t-Mobile SIM card after power off.

    After power back up, If it prompt for SIM changed, just wipe away the pop up message.
    Hotspot feature still works. Here is the view from "Network Single Info"

    Net Operator: Hutchison 3G UK/Hutchison 3G UK
    SIM Operator: < Your invalid/inactive SIM carrier name >
    Net Type: Unknown
    Net Strenght -91 dbm * 11 ASU
    Data State: Data connected
    Data Activity: upload+download activity
    MNC: 20
    Country code: < Your invalid/inactive SIM Country Name >
    IP :
    External IP: Can not get external IP
    Roaming: Roaming is OFF
    Phone type: GSM

    This solution also works if you have 2 freedompop Data SIM card and need to swap in and out of SIM card in the middle of each month. Just be sure to insert the freedompop SIM into the same SIM slot. ( I tested once again, insert the Freedompop SIM card into the SAME SLOTS does not need to re profile SIM. )

    Again. This solution only works if you have T-Mobile Pay as you go voice only SIM and enable 4G dataplan before switching to Freedompop.

    This may not be a very detail or may be some steps are not needed , but let me know if I miss any steps, I will update this thread as needed. thanks

    If anyone able to get this trick working on others dual SIM phone ,plz reply.

    Update: LTE Band 12 can be reenable using "
    "MTK Engineering Mode" Android App. Please see below for detail.

    Post edited by Blu R1 HD User on
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    edited August 2016 #11
    Today, I downloaded the "MTK Engineering Mode" by "TheMonster" from App Store which give you additional setting /information about which 2G/3G/4G currently in use by this BLU R1 HD , plus it is able to ENABLE LTE BAND 12, since I do not have T-Mobile data plan, I can only tell it is enabled but not able to make use of it yet.

    I was able to select and enable BAND 12, I also checked LTE info, it returns the following BANDs are supported "2,4,7,12,17" ( you need T-MOBILE SIM to return those info)
    UPDATE: Band 12 will turn off when SIM card removed, so this is not a permanent solution yet, need BLU firmware update to enable Band 12 permanently)

    However, it does not do any good with Freedompop yet.

    In this app, I also enable "Mobile data service preferred" to FULL SPEED. it give the following message
    " Moble data service preferred is used to improve the data transmission efficiency at the cost of lower call receiving rate. Not recommended to do so"
    However, it does not give too much speed gain with Freedompop data throughput. ( More Throughput test is need)
    With this App, I can confirmed that only single SIM can get 2G+3G+4G data:

    ( GSM Mode: EGSM900,DCS1800,PCS1900,GSM850, UMTS Mode: WCDMA-IMT-2000,WCDMA-PCS-1900,WCDMA-AWS-1700,WCDMA-CLR-850, LTE Mode: Band 2,4,7,1217)

    The other SIM have to fall back to 2G ONLY.

    (GSM Mode: EGSM900,DCS1800,PCS1900,GSM850)

    I do see all others LTE BAND up to Band 44 but unable to select any of those ( due to grayed out) , I was only able to select Band 12 .

    In other word, In case you have 2 Freedompop SIM ( since freedompop use 3G/4G for Voice ), it is NOT possible to get Freedompop voice call from SIM A (2G) and Freedompop Data (3G/4G) from SIM B at the same time.

    Update: Anyway ,with above setting, Blu R1 HD , with HSPA+ enabled

    Using Android App reports the following:
    Download speed up to 10.64 Mbps. ( it takes about 5 seconds to ramp up to 10 Mbps download speed)
    Upload still only 1.64 Mbps ( ramp up very fast)
    Ping time is still around 369 ms
    Post edited by Blu R1 HD User on
  • kgirishkgirish Posts: 3FreedomPop Newbie
    I have BLU R1 HD. Tried all above things still getting Error "Unable to register on Freedompop Server. Could anybody help?
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Kgirish, You may hit a SIM activation issue which is not related to BLU R1 HD, Have you call freedompop Customer phone number and ask if your SIM activated yet??, If so, Try another phone from your friends or Families ensure the SIM is in service before play around with this BLU Phone.
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Hi, Have not post any news on my BLU R1 Phone with freedompop SIM , but recently since there is 2 MAJOR patches, 1 for security and 1 for enable TMobile BAND 12 . Just to report that after the latest patches, Dual SIM + hotspot connection still working fine with Band 12 ( new feature , plus Major Spyware security fix) see below URL for security detail.

  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    My freedompop 4G LTE SIM card is on its way, I shall report how fast , or if this Blu R1 HD even work with Freedompop 4G SIM soon. Stay Tune.
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    edited April 6 #16
    Here is my Initial Review for 4G LTE SIM $0.99 + tax with BLU R1 HD cell phone.

    I just got 4G SIM card and just test with BLU R1 HD, once put the SIM into the first slot , just setup to use APN "" ( DO NOT NEED TO enable ROAMING ANYMORE) , I see "4G LTE" right away.
    after re enable th Roaming , DO not see any speed different.

    If you google "", you will see more info about this 4G SIM.

    Here is more IP address info: , this is U.S. based IP address , which should have no UK regional restriction issue when compare to my old Global 3 - in 1 SIM

    For Speed , I tested with 2 devices , Samsung Note 3 ( N9005) which DOES not support ATT 4G LTE, so, it only show H+
    SpeedTest for Samsung Note 3 reported only download:1.83 Mbps and upload: 0.68 Mbps, ping= 47ms

    Speed test for ( with roaming OFF) BLU R1 HD reported download: 1.79 Mbps and Upload: 6.08 Mbps , ping=83
    Speed test for ( with roaming ON ) BLU R1 HD reported download: 2.77 Mbps and Upload: 6.08 Mbps, ping=58

    For ( Smasung Note 3 , with speed H+ , upload is slower than download
    For BLU R1 HD, with 4G LTE, upload is way better than download. Need more test with various location to check the MAX download , since I have 1.5G in first month, I will try different location in next few days.

    In Both phone reported this is a ATT SIM card. so default APN show 2 APN for ATT as well -> ( ATT Boardband and ATT WAP) of cource , in order for this 4G to conenct, it need to add APN with ""

    So my next test with check, stay tune,or if anyone want any test , Please reply.

    1) Check if Google phone able to detect this is a US base IP during call.

    2) Check if this BLU Dual SIM phone able to enable internet sharing trick that I posted in this threat for Global 3- in 1 SIM.

    3) my Next Month, Check if I really get 700MB ( with 500 MB from friends) still works for BOTH my Global 3- in 1 and this 4G LTE SIM card.
    4) currently I only sign up for $3.99 data plan roll over, so will see how much it cost me .

    Post edited by Blu R1 HD User on
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    edited April 4 #17
    Hi, Just re test the 4G speed test while point to a better Cell tower,
    PS: this 4G LTE Net operator is "Broadpoint inc" reported by "Network Signal Info" app

    Speed Test #2 for BLU R1 HD reported download: 5.48 Mbps and Upload: 21.7 Mbps, ping=60
    ( yes I did not mix up upload and download, again, upload is much faster than Download in both Test 1 and 2)

    Also tested 4G LTE Tethering works just fine.

  • Rich Sias (16th)Rich Sias (16th) Posts: 2,468FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    Wowzers !!! that is some humdinger of an upload speed !
    When you try this again and get the big upload. Try for a comparative test, just to be sure it is really not backwards. If you still have enough data left for testing.
    Be my Valentine ZTE, Victory, LG Volt, & 803S
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    edited April 5 #19
    Hi, Rich, I did try with and from Ookla, upload and download varies base on location. The following using as well as ( the different between 2 apps reported are very little)

    Speed Test #3 near SJ,CA reported download: 27.49 Mbps and Upload: 11.05 Mbps, ping=30

    Speed Test #4 near SF,CA reported download: 6.32.49 Mbps and Upload: 23.72 Mbps, ping=29

    Still unknown why some cell towers give different upload and download speed?? Not sure this is AT&T issue or Freedompop APN issue?? any idea?

  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    For more info about 4G vs 4G LTE testing with this BLU R1 HD, please review the following URL
  • Blu R1 HD UserBlu R1 HD User Posts: 46FreedomPop Newbie
    Today is first day of my second month of using 4G LTE (AT&T network) with BLU R1 HD, the Hotspot feature just working fine , no roaming needed, Also does not need any trick that I described in this topic for 3G UK base Global 3 - in 1 SIM . Highly recommend 4G LTE to my friend. However, I was told and reading this forum that additional 1 to 2 US dollars charge may apply if SIM card usage under 5MB each month. so just make sure if we have 2 SIM cards, use it to avoid idle service charge.
  • Rich Sias (16th)Rich Sias (16th) Posts: 2,468FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    The $0.99 idle fee was dropped about 3 years ago when I fist became a subscriber. Complain if you are being assessed.
    Speed test #3 seems sensible. The other ones #1, 2, 4 all seem backwards. Like a programmer got it backwards in the app.
    You speed test will vary greatly the more you move farther away from the tower.
    For a 'guessed' example:
    @ 500 ft you might see 41 mb/s
    @ 1000 ft you might see 23 mb/s
    @ 2000 ft you might see 9 mb/s
    With upload speeds 1/3 to 1/5 of that.
    That's assuming you "see" the antenna on the tower and not blocked by any hill, trees, buildings, etc.
    Be my Valentine ZTE, Victory, LG Volt, & 803S
  • johnsuegjohnsueg Posts: 1FreedomPop Newbie
    I am using Blu r1-hd with consumer cellular and freedompop sims,and have tried your hybrid method of setting up phone but when I set freedompop as data useage it kicks consumer cellular out and can not use it for calling evevn if it shows it selected for calling and texting.
    Any sugestions...the freedmopop sim is the 4g lte
Sign In or Register to comment.