custom rom on galaxy s4

marklybargermarklybarger Posts: 13FreedomPop Newbie
i have a samsung galaxy s4. it was shipped from freedompop downloading an update constantly that it could never update. i disabled the notification, but thought i'd try a new rom. i've installed first the TWRP for us sprint s4. next, i installed cyanogenmod 13, along with google apps. the phone works pretty good. i can make calls, but it's seems to be on premium voice? not sure. it uses the stock dialer. i installed the fp messenger to send text, but can only send on wifi. i can never get mobile data to work. I just don't know where to look to solve this. mobile data was working fine before switching.

any help is most appreciated. telling me that i voided my warranty on a 3 year old phone is not helping. what kinds of things can i do to troubleshoot? where can i get a freedompop rom? or even a vanilla android for the phone? i've only been able to find this cm13.

thanks!

Comments

  • RoytatoRoytato Posts: 84FreedomPop Newbie
    Search online for Rwilco12's Android Repository he's got S4 stock rom I think. You'll probably want the sprint Rom.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    Stock SPRINT ROM has bloatware. I seem to have bricked my S4 trying to follow support's instructions for Factory Reset when nothing else got my phone working again with FP (purchased from FP with their ROM). Boots to Galaxy S4 and stays there until battery is dead. Where can I find the stock FP ROM for this phone? I just ignore messages to update. Data and texting via 3G both used to work but the sound is very weak and headphone jack was dead on arrival. (LTE signal is too weak to use).
  • trackballtrackball Posts: 1,583FreedomPop Newbie ✭✭✭✭✭
    edited November 2017 #4
    if you're using the stock dialer, then doing a sync acct data may not get you off wi-fi, but try this, open fp app, tap 3 bars, top right, droid only, scroll down, tap sync acct. test off wi-fi.

    too late, didn't see 2016.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    Here are Ana's instructions to do a Factory Reset, excerpted from a previous support ticket (quite long and with other error's on Ana's part). Previous support ticket to that was with Ryan, who got one of three FP phones working again (Viper, Android 2.3).

    -------------

    If is still not working please make a back up of your data and follow these instructions to do a factory reset:

    Turn off the phone. Press and hold at the same time Volume UP,Home and Power keys. When you see Galaxy logo release the Power key but continue to hold the Volume Up key and the Home key.

    Release them when the Android System Recovery screen appears. Use Volume Up/Down keys for navigation and Power On key for OK. Choose "wipe cache partition", "Yes -- delete all user data", "reboot system now".

    (The vol up/down keys did not navigate but there was a touchscreen menu).
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    I posted two other longer copies of support tickets before this one and am waiting for them to be approved. I have informed FP that if my posts are not approved I will escalate the case to the FCC. I want to have a working S4 with or without FP. It worked fine with wifi until FP 'helped'.

    The above instructions are incorrect for my Galaxy S4 and bricked it. Someone said they are for an iPhone 4S. DO NOT FOLLOW THEM!!!!

    After waiting a month for help restoring the ROM that their instructions messed up, FP claims that the phone which was purchased new from them for over $100 is BYOD and that they are not responsible and I should buy a newer phone from them. I have been through three support agents on the latest support ticket, all of them telling me to wait for management to fix the problem that they escalated.

    Can someone more knowledgeable in the forum explain where to find a copy of the FP ROM for the Galaxy S2 and how to reinstall it using TWRP (which was on the phone at the point where I tried to follow Factory Reset instructions)?

    If I reinstall the FP ROM, will my account still be active? If not, I will attempt to install some other ROM (probably stock Sprint) and sign up the phone with a company that offers honest support, and where two of three phones do not stop working suddenly due to software updates.
  • Rich Sias (16th)Rich Sias (16th) Posts: 3,338FreedomPop Newbie, FreedomPop Master, FreedomPop Expert ✭✭✭✭✭
    @Cynthia Keesan See first message at top, references a source of S4 ROM. If you are unable to locate a FP ROM for your S4, go with one that can work for you. Maybe a compact one to leave more free space for you. The FreedomPop Messaging App just runs on top of the Android. Most of the BYOD phones are able to work this way. Once you install the App, open it and it may ask for you to login. Try the phone number as ID and your normal password. Maybe 3x if necessary. If still no go, then use your email address as ID and password.
    If on a Sprint phone, do the PRL & Profile system updates.
    In the app is option called "Sync Account Data" - run that last. Your browser should search internet. Then from inside the app, make your first phone call. If successful, then the native dialer should work for Android phones. All texting must be done from inside the App. If you need step by step setup instructions, just ask.
    Be my Valentine ZTE, Victory, LG Volt, 803S, & 4 SIMs
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    Thanks for your helpful advice. I have not found a FP ROM.

    I filed a complaint with FCC and on Jan 9 they contacted Freedompop. FP was given 30 days to respond in writing. The response was, as usual, they are 'escalating to management'. They remind me of this every few days. They won't tell me where to get a FP ROM. But they have stopped claiming it is a BYOD phone. I ask for a replacement phone and they say to buy a new one. I ask for a refund and they say my phone is out of warranty.

    I am concerned if I replace the ROM they will claim I no longer have an account with them. I can hunt for instructions how to use TWRP and for the Sprint ROM for the S4. I know it has to be a stock ROM (with NASCAR and other bloat) to get it working with FP, but can then be switched to Cyanogenmod (with minimal google stuff). I did that with an Epic 4G (which stopped working with FP though it has a good signal).

    But as I recall I could not even get into TWRP again after bricking the phone by holding the right buttons. I will try again in 15 more days.

    For the second time, I no longer have a phone number because it expired because I cannot use it on a non-working phone. VOIP only works here via wifi. Download speeds are 150-300kbps via 3G and slower via LTE (weak signal).
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    Once again, FP support has COMPLETELY ignored my request for a FP ROM and addressed only the part of my ticket where I say if they are incapable of helping me get my phone working again to replace or refund. Management, they say, says the phone is out of warranty. I suspect a computer is reading what I write and responding to one word.

    Today I kept it simple. "Where do I find a FP ROM for this phone".
    The response is sure to be "We are escalating to management".

    The phone was bricked by following instructions from an incompetent support person, apparently for a different phone. FP subsequent support has not once addressed this problem, other than telling me I am not allowed to delete the ROM and it voids the warranty. Which is why I suspect the support people are mostly computer programs.

    I have found at XDA Developers several Sprint ROMs. 650MB non-color English only. 790MB color all languages. Do I want deodexed debloated? Is there anything smaller around? I need a Sprint ROM to get the phone working with FP (assuming they do not claim I have voided some provision of the contract by replacing the ROM) after which I can install Cyanogenmod ROM.

    After charging overnight, I can hold down HOME, Power and Vol Down to get to a screen that warns me I can cause problems by downloading a ROM to the phone and to hit Vol Down (?) to cancel or Vol Up (to install).
    I may borrow a friend's better battery to install with.

    Will I need anything besides the ROM itself and the TWRP which I previously noticed was on the screen when I tried to follow misdirections to do a factory reset (for iPhone 4S, apparently)? Does the ROM go any place particular on the microSD card? (Obviously I will not be downloading it via the phone itself).

    The stock ROMs I have found are Android 4.3 and the phone used to be Android 5.1.

  • trackballtrackball Posts: 1,583FreedomPop Newbie ✭✭✭✭✭
    another old 1, believe it's 4.?, and only a update.
    forums.freedompop.com/us/discussion/13482/samsung-galaxy-s4-android-system-update

    did you try to contact ramdxen ?
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    Who or what is ramdxen? The other discussion referred to above is about the automatic update that keeps uploading onto this phone, and someone's problems trying to use ODIN. It appears that TWRP is already on the phone. I guess I have nothing left to lose by experimenting with whatever Sprint stock ROM I can find and will start with the smallest 650MB deodexed debloated 4.3 (4.2?) and then I can flash something better after getting it to work again with FP (or not). It came with a 5.1 Sprint ROM (debloated).

    Thanks for trying to help.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    The stock Sprint ROMs that I found include the stock Recovery partition which would wipe out TWRP. I did find and download TWRP and CWM for this phone, but then I would need to install them again using a computer with ODIN (and Windows - I use linux) or some other way. Can someone steer me to a stock Sprint ROM that does not include the Recovery partition? I ran across one but cannot find it again.

    FP support continues to be non-supportive.
  • [Deleted User][Deleted User] Posts: 3,553
    The user and all related content has been deleted.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    The latest support person actually read much of what I wrote. I asked repeatedly for a link to the Freedompop ROM so I could flash it with TWRP that is on the phone. She wanted a photo. I sent a photo of the boot logo. She understands that I need to flash a ROM. I sent a link to a page explaining how to flash the stock Sprint ROM using ODIN to the Galaxy S4. She sent a link to a very similar site for the Galaxy S4 S5 and S6, to flash stock ROM using ODIN. Everybody has continued to ignore my request for a FP ROM.

    I may need to put on the stock ROM with ODIN (and Windows), attempt to get the phone working again with FP, and THEN put on ODIN again and replace Sprint ROM with Cyanogenmod (android 5.1 instead of 4.2). Sprint ROM is bloated and wasteful (and slower). Maybe I can at least flash Sprint ROM with TWRP and then load TWRP again.
  • Thomas GunnThomas Gunn Posts: 13FreedomPop Newbie
    I dabbled with CM last year but had too many issues. Mainly being CM doesnt support PRL updates. I ended up reflashing back to stock sprint rom
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    I seem to have wiped out TWRP in the process of following Ana's instructions to do a factory reset by holding down three buttons. I wiped Dalvik and data and system, I think.

    My battery was good for a few minutes so I spent $13 on a new one. I also have a new SIM card which FP said was my problem (but did not fix the problem of no FP signal).

    I have been trying for two days to flash TWRP or CWM to the phone so that I could then install a new android operating system with one of them.

    First tried with Windows 7 (not genuine - someone gave me a laptop with it).
    Installed Samsung drivers for the phone, and Odin.

    I read instructions for using ODIN to flash TWRP at 10 or 15 sites.

    Got the phone into download mode (charge battery 12 hours seeing only a battery symbol, remove back cover, remove battery to turn off the phone, replace battery, hold VOL DN, HOME and POWER about 5 seconds until you get a buzz and a message on the screen YES or NO, release buttons, press Vol DN to get DOWNLOAD mode).

    Started ODIN. Plugged in the phone. Win 7 (not genuine) kept trying and failing to download the Samsung drivers despite their being installed already, every time I plugged in the phone. The first time I plugged it in, Odin (3.10.7) found the phone (but I did not install anything, was just experimenting at the time). After that it never found it (using a USB port and cable that works for USB file transfer from another phone).

    I rebooted twice, reinstalled the drivers, etc. Gave up on Win7 and switched to XP.

    Installed Samsung mobile drivers and latest Odin 3.10.7 (I tried 1.85 but it did not work).

    Plugged in the phone and it was 'Added!'.

    I checked AP box and Browse and browsed to and Opened TWRP (or CWM for GalaxyS4 Sprint) tar file(s).

    Clicked Start. Odin engine ID... File analysis .... (waited 10 minutes - it should immediately have started to flash the file to the phone).

    There are various technical explanations and possible fixes for this problem which i could not even understand. One fix was to take the phone in for service.

    That is as far as it got. I tried three different cables and two recovery .tar files.
    Should I try an older 2.6.3 or 2.6.0 twrp?

    Should I repartition or anything else before flashing TWRP or CWM?

    The USB port is in a PCMCIA card because this laptop has dead onboard USB.
    The Win7 computer has good USB ports. But it runs much more slowly (though four years newer with 2GB RAM instead of .75GB). I thought the SAMSUNG drivers would never get around to even starting to install.

    Should I try to install the Sprint stock ROM directly with ODIN? There was something about a PIT and a third file not just the .tar or .zip file.

    I had hoped to install only 250MB of CM12.1 (Android 5.1.1) instead of 650MB of Sprint, and then add 92MB of pico gapps (minimal Google instead of 350MB of Google apps). I found a debloated deodexed but not rooted stock Sprint ROM 5.0.1, the version that the phone was sold with by FP.

    I can look for and learn ADB in linux, but I was able to install CWM, CM, and again stock ROM to an Epic 4G (Sprint) with both XP and Win 7 a couple of years ago. (The Epic 4G also stopped working with FP. It needed stock Sprint to activate but not to run, but some update broke it).

    I read that all Verizon LTE phones can now be used with AT&T after they are used with Verizon for 6 months. A friend got his Verizon S4 working with an AT&T reseller (Airvoice) by changing some data settings. Might they also work with FP and a SIM designed for AT&T phones? AT&T LTE is much stronger than Sprint's (unusable around here - slower than 3G, which is 150K to 350K download outdoors - such that 500MB would take hours or days to use up).
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    I can now do the 250MB Stagefright security update, which was not possible with the FP ROM even though the phone kept wanting to download and install it. This update is the same size as Cyanogenmod 12.3 (without google apps). It took a few minutes then rebooted.

    "Android is upgrading. Optimizing app 14 of 214...." (replacing 214 built-in apps for security reasons). Another few minutes. Like 10. Android is finished upgrading and is checking device status (trying to hook up with Sprint?). Welcome to Voicemail. Date and Time...

    Google Account, Play Store, Freedompop Message App/free SIM (ignore the SIM part since I already have a SIM and an account). Interrupted by download of three gmail messages (I forgot to disable gmail). Open Messaging - 'Contact customer support to activate'.
    Back later.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    With new stock Sprint ROM 5.01 for L720 and FP Messaging app installed (and gmail account to use Google Play to get that app), I went to FP website and Activated and chose a new phone number. They mailed me confirmation. Google also sent two mails urging me to download important apps (Photo app etc.). I used Phone to enter ##72786# for PRL update as instructed, which rebooted the phone. 'My Sprint Launcher' installed itself. Gmail downloaded three mails so I disabled gmail (I don't use it) and many other unwanted apps. Default is to use CDMA (3G) not CDMA/LTE. I will install Signalcheck Lite.

    I then tried to send a message with FP Messaging, confirmed that I wanted it instead of Google version, and now get an endless Loading with a blue circle chasing its tail. (And ads at top of Messaging page).

    I may be missing a step, or just back to where I was before I wiped out the FP ROM.

    There is ANOTHER Software Update. 319MB security and new features and bug fixes. Installing system update..... Down to 79% battery (good way to get it to zero to calibrate is to install updates). Optimizing app 72 of 216. (Replacing everything it replaced with the first update?). 210 is a big one.

    It rebooted. Refreshing SIM data.

    Messaging. Locating user for device .... Your phone number is. Loading....

    Hands free activation (Cancel - Sprint wants to activate).

    Back to the Support page.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    To finish making Messaging load, click on the parallel lines in upper left, then Sync accounts. I now (again) have a phone that will not access the internet via phone signal. 3G or LTE. (Messaging or Browser). Two different radios. if just one, I would suspect the phone transmitter went bad. I know the signal is weak but it was weak a year ago when it worked. I should probably give up and switch carriers.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    Third update 329MB. Usable LTE signal on porch (-109 dBm) but no internet connection.
    I succeeded in draining the new 5040 mAh battery to 59% ;=)

    The phone rebooted by itself twice more since the third bug fix update. Time to try a custom ROM again. (And another carrier to test if this is a software or hardware problem).

    I tried calling 611 Sprint - Network not available. Should have done this test before installing FP app. 56%.
  • Chris ColemanChris Coleman Posts: 55FreedomPop Newbie
    @Cynthia Keesan
    1. As far as I know, there's no such thing as a FP ROM, FP uses the stock Sprint ROM + FP dialer and texting app, running voice/text, on data connection, over the top of the stock android OS ROM.
    2. There are ways to remove extra "bloatware" apps from the stock Sprint ROM, and pare it down to just stock android, and free up that storage space. This is very popular to do. Search youtube and xda for how to.
    3. You might be in an area with terrible sprint signal. You should try going to an area with known strong sprint signal and test it out there for a short time. There should be no issue at all with your 4G LTE internet speed in a strong sprint signal area.
    4. You might wanna look into switching to the FP LTE SIM and an ATT compatible BYOD device, such as most verizon LTE phones (all Vzw LTE are unlocked for any compatible US carrier, as long as they support the RF bands), any unlocked ATT compatible device. Google sprint byod unlimited for more about this. Many phones these days are unlocked and compatible with all 4 major carriers. For example, Moto G5s Plus, Moto Z2 Force, iPhone 6, Samsung S7.
  • sindi keesansindi keesan Posts: 23FreedomPop Newbie
    Thanks for all the info and suggestions.

    1. As mentioned in the first post on this topic, the ROM that shipped with the hone kept downloading an update but refusing to install it. After I flashed the 5.0.1 stock ROM, the phone automatically looked for and installed three updates. Later it installed a fourth update. So something was different besides the Freedompop messaging app.

    2. Removing bloatware requires getting root (by flashing a rooted Sprint ROM or other custom ROM, or by some other method). I disabled a lot of apps that were running without being asked to, to free up RAM. The phone has plenty of ROM (storage) so I will leave it as Sprint for a while.
    (Also I was unable to install a custom recovery partition which I would need for a custom ROM, but maybe I could do that now).

    3. The Sprint towers are 3 miles SE of us, with higher land between.
    On the phone with working 3G (CDMA) and 4G (LTE) I used testmy.net to measure download speeds of 1.4Mbps LTE (range was 84 to 0.7, peaking abruptly then dropping to almost nothing) and 1.8MB 3G (steady signal).

    On the S4 I had been measuring -.99 dBM 3G and -114 dBm 4G (or worse) with NO download at all. I had set the phone to CDMA only because that is faster than CDMA/LTE on the other phone (it no longer has to keep looking for a weak signal).

    Today the support person gave me the usual instructions about installing Messaging App, synching account, then ##72786# (which I had done repeatedly yesterday) and updating PRL and Profile. Yesterday I was unable to update either (nothing happened).

    I dialed ##72786# again and this time it rebooted and updated PRL and then I noticed the phone had switched from 3G to 4G (in settings it was back to CDMA/LTE) and had 4 bars of signal (instead of the usual 0-2). It now accesses the internet and downloads at 1.4 Mbps until I switch it back to CDMA only at which point I get no internet again.

    Signal Check Lite was showing the usual -99 dBm and -114 dBm (as high as -93dBm south of the house) until the PRL update after which there was no longer any CDMA signal at all.

    My theory is that the CDMA radio was dying and the reception was okay but it was not transmitting, and it finished dying at which point things started to work because the phone had to use LTE.

    Is there any app that will turn off the CDMA phone radio and use just LTE?

    My other nonconnecting FP phone is 3G only and if it has lost the ability to transmit it is useless with FP. I can probably use it for voice and text with another carrier. A second identical phone (Samsung Epic 4G) lost its 3G signal entirely. (And they both can't tell time, and one no longer does USB file storage....). I had to flash a stock Sprint ROM onto the first phone to make it activate with FP, but could then reflash Cyanogenmod.

    4. My partner has an AT&T-based phone. He has to go outdoors to make phone calls because that signal is even worse. It does 3G and not 4G. (No 2G - AT&T dropped it). He mainly uses it for texting. I suspect AT&T is putting more power into the 4G/LTE signal and/or a wavelength not supported by his phone. (My neighbor gets a fast LTE download). The tower is 3/4 mile from here.

    A Sprint phone with 2G is fine here for voice. If I used the S4 for voice I would pay the $4/month for 2G but the sound is too weak.

    Has anyone activated an AT&T (or unlocked GSM, or Verizon LTE) phone with custom ROM with FP?

    With a stock Boostmobile or Virgin Mobile phone? The latter would not do data with Ringplus. Will they do data with FP?

    A MetroPCS phone and a friends Verizon phone had to have some settings changed to do data with Airvoice Wireless (AT&T MVNO - highly recommended for competent support). A Boostmobile feature phone (2011) works fully with no changed settings with another Sprint MVNO.

    The closest of two Sprint towers is 3 or more miles southeast. We are in a depression and the Sprint signal map shows weak signal here and much better signal just west of town. I get a 5 bar signal at the river to the north (in a valley but probably straight line of sight to the tower).

    My S4 is now usable (after only ten months of sabbatical). The new battery only lost 35% charge in 24 hours (airplane mode on, and all unused apps disabled and notifications off). It should last a day of normal use (occasional text and checking email). The sound is too weak for streaming audio or even wifi voice. I have 500MB 200 min and 498 texts to use before March 3.
  • Chris ColemanChris Coleman Posts: 55FreedomPop Newbie
    @sindi keesan
    To answer your questions about will this phone work on this carrier, there are 2 websites for this. https://frequencycheck.com and https://willmyphonework.net These sites compare the RF radio frequency bands supported by the phone you select, with the various mobile network operators.

    To answer your question about signal strength, Sprint makes an awesome LTE signal repeater, called the "Magic Box", which you place in a window where the signal is strongest, and it will receive and re-transmit the LTE signal to your home, and to all the Sprint customers in the nearby area. The cost is free, you just pay for the minimal electricity usage per month, maybe $1. Just call Sprint telesales and ask for the Magic Box.
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    I have read that Sprint phones will not work with any other network but Verizon LTE phones will work with AT&T, and also that Verizon was selling unlocked phones for a few years but has or will shortly stop doing that.

    A friend with iPhone and Sprint service checked download speed here and got 333Kbps. I get as high as 1.4MBps indoors near a window. Outdoors the signal strength is only slightly better and the Sprint coverage map also shows our immediate area with poor coverage. Signal Check Lite showed for LTE download speed a brief spike and then a nearly level line close to zero. The spike is unlikely to be amplified (it already hit 84Mbps) and twice zero is still not much. But the Galaxy S4 is on the list of phones that will work with the box.

    I do not use LTE at home. We have wired internet and VOIP phone (free with an ATA device using Google Voice to make calls). The existing signal works for texting, email and browsing , and there seems to be wifi everywhere indoors (and even outdoors near stores).

    I am considering replacing the FP ROM (Android 2.3) on my LG Viper with Cyanogenmod - a 4.0 or later ROM (required by my email provider).
  • sindi keesansindi keesan Posts: 23FreedomPop Newbie
    Yesterday a friend with iPhone and Sprint service checked download speed here - 333Kbps (0.333 Mbps). He is paying Sprint for 10GB/month and uses the phone as a hotspot at home. I wonder how he manages.

    Today a friend with Sprint Galaxy S4 using Tello got 10.9 Mbps of steady good signal.

    I rechecked with my S4 bought from FP and got 1.3Mbps (-117 dBm).

    The LG Viper bought from FP got 1.4MBps as did the S4 two days ago during a snowstorm. Both with LTE. Viper with 3G got 1.8Mbps.

    I would not purchase a phone from FP if these two are typical. The S4 also has very weak sound and dead headphone jack. My neighbor bought it with dead battery and FP ROM and gave it to me when an update broke things.

    I found instructions how to turn off 3G.
    ##7764726
    # 6 ZEROS ( 0x6) --- this may mean to type #000000
    Test Mode
    Network Mode
    LTE only
    Back arrow on soft keyboard
    Phone reboots.

    This would make a useful diagnostic tool for phones with 3G and 4G
    that have a signal but will not connect to internet. I no longer have any 3G signal (according to Signal Check Lite).
  • Cynthia KeesanCynthia Keesan Posts: 37FreedomPop Newbie
    After I reported to Freedompop that the LG Viper and the Galaxy S4 purchased from them both have very poor reception (compared to the same model in the same location) and that the S4 has very weak sound and dead headphone jack and now dead CDMA radio, the support person suggested that I 'upgrade' to a newer phone (purchased from Freedompop).

    These phones work for email and texting.

    I wonder if they are making bulk purchases of 'refurbished' phones, meaning phones other people returned because of problems.

    But then two other high-end Samsung phones purchased elsewhere (Epic 4G) also lost their CDMA radios, and clocks, and the sound is failing, and one lost USB storage ability.
Sign In or Register to comment.