Improve Voice Quality on Your FreedomPop Android Phone

If you are having voice quality issues with your FreedomPop Android phone please try this:

-Go into app settings,
-Under network - check use compact sip
-Under media - change clock rate to 44.1 khz

Comments

  • James KingJames King Posts: 0FreedomPop Newbie
    Does this require more bandwidth and add more delay?
  • pyoo75pyoo75 Posts: 3FreedomPop Newbie
    what's app settings? or where is it?
  • Adolfo GalvanAdolfo Galvan Posts: 720FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FP Flyer ✭✭✭✭
    pyoo75 said:

    what's app settings? or where is it?

    Press the menu key. Then settings.

    Does this require more bandwidth and add more delay?

    The clock rate is a local function. It will only affect how your phone deals with the audio, not the rate going over the internet.

  • Adolfo GalvanAdolfo Galvan Posts: 720FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FP Flyer ✭✭✭✭
    edited May 2014 #5
    Here is an explanation about the clock rate and codecs from the CSIPSimple forums (the program FP Messenger is based from). https://code.google.com/p/csipsimple/issues/detail?id=1322
  • James LivingstonJames Livingston Posts: 8FreedomPop Newbie
    I cannot find where to check the setting detailed at the beginning of this thread.
  • Joe BallouJoe Ballou Posts: 4FreedomPop Newbie
    Hi James - they are referring to settings within the FP Messaging app. (I had to figure that out after looking through the phone's (Samsung Galaxy S2) settings).

    So, tap on the blue Messaging app -> menu key -> Settings -> Network -> scroll toward the bottom for "Use compact SIP" (mine was already checked)

    Then after adding the checkmark, return key and notice "Media" directly below the Network category. Tap that and find Clock Rate, tap that and set it as described above.

    Unfortunately for me, those were already set. My call quality is fine on 4g or wifi, but there is a 1-2 second delay in transmission times, so I am constantly interrupting the person I am speaking with. ??
  • Emily NguyenEmily Nguyen Posts: 0FreedomPop Newbie
    I set my phone to the setting above but still having problems with echo delay. What else can I do ?
  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    For anyone with battery life issues and are rooted, get a CPU clocker app and under clock your device slightly and then your battery will last a bit longer. Please note that your device will perform less faster if this is selected.
  • robert koffrobert koff Posts: 0FreedomPop Newbie
    Thank You Ali.
  • Ken BaughKen Baugh Posts: 1FreedomPop Newbie
    Thanks for you post Joe. but like you, my setting were alright like that. sound quality is still an issue and all i get on the other end of the phone is "what did you say?"
  • Fernando IglesiasFernando Iglesias Posts: 0FreedomPop Newbie
    Yeah I have noticed a slight delay of maybe 1 second on 4G LTE and Wifi. On 3G sometimes its 1 second, but mostly its 2seconds of delay with the occasional I can't hear you, even though I can hear them. The new update to the app hasn't really helped much with this problem.
  • John RakisJohn Rakis Posts: 1FreedomPop Newbie
    I've never been able to make a call without the annoyance of a delay, even when using 4G. And even though I live in a city with good 4G coverage, it's hard to get it consistently. About the only thing the phone is good for is checking e-mail and accessing the Internet which it does quite well. So I find myself, like others, carrying two phones which is inconvenient.

    I'd be willing to upgrade to one of the the latest phones and plans, but not until I see a lot of positive reports about call quality for users.
  • Ali Ali Posts: 6,705FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    edited June 2014 #14
    @Jrak I think you need to get an LTE phone if you are willing to upgrade as LTE is a heck of a lot faster than WiMAX.
This discussion has been closed.