**Reminder** When you sign up for FreedomPop service we often offer a free trial experience for one of our plans or add-on services. Upon the end of your Trial, you will incur the regular charge for that plan or service. Please take a look at our Community post for more information regarding your recent purchase and what to expect: http://bit.ly/2xFTGWY

IMIE check failing for iPhone 6S / 6S Plus BYOD device

freedom123freedom123 Posts: 1FreedomPop Newbie
I am trying to activate iPhone 6s/6s Plus SPRINT devices from the Freedom BYOD interface https://www.freedompop.com/byod. So far I tried ~20 different IMIE #. IMIE check is failed for all of them. I tried reaching out to Freedompop Sales, Activation and Technical support teams but they are not helpful at all. Every time I am reaching out to them with new IMIE#, they are simply saying this particular device is not in our database of compatible devices. 20 out of 20 devices cannot be wrong. BTW all of the 20 IMIE # that I tried so far are passing IMIE test on Sprint and ready to activate it them on Sprint network.

I know there is some issue going on between Sprint and their MVNOs where Sprint is not releasing devices to activate it for MVNO networks.
Just wondering if anyone have recent success in activating 6S / 6S Plus devices on Freedompop.
Appreciate if you share your experience on how to make it working.

Thanks

Comments

  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    @freedom123 Remove the last number from the IMEI number and try again. You should be able to activate them all.
Sign In or Register to comment.