MiFi 500 LTE - Service Error "Your FreedomPop device is not Found in our system."

jeffv13jeffv13 Posts: 0FreedomPop Newbie
I've been successfully using this device since April and internet stopped working this month.(possibly around the time of plan period reset). The device DOES connect to the Sprint LTE network successfully with no problem, however all mobile devices get redirected to the https://setuplte.freedompop.com/sprint/activatelte webpage. This webpage displays the following message:

"Service Error - Your FreedomPop device is not found in our system. Please contact customer service for further assistance. "


I did contact customer service and after a VERY long wait reached someone who had me do a hard reset which completed successfully and the device downloaded a new profile and PRL.

After the reload my device still connects to the Sprint LTE network with no problem but blocks my internet with the above message. Customer support claimed they were going to escalate the problem and I would receive an email(yesterday). However, I have yet to receive any email and my service is still non-functional. I am in an excellent Sprint LTE coverage area and never have trouble connecting at LTE speeds, I just cannot get internet access once connected for the couple weeks.

From looking through this forum it looks like this is not a isolated incident with the Sprint LTE mifi service(since May). Anybody get this problem resolved and know what the true cause of the problem is?

Thanks

Jeff

Comments

  • ???? ??????? ??? Posts: 64FreedomPop Newbie
    I have had a very similar experience. In fact, it was the same screen with the a slightly different/better customer service experience. The fact remains this problem is wide-spread and it needs to be fixed. I am also waiting on an email from the dev. team. This is taking a while for me. It has been about a week since the customer service escalated my issue. -Blaine
  • [Deleted User][Deleted User] Posts: 31
    @jeffv13‌ - I have reviewed your account and the issue requires escalation to our development team for a fix. I will let you know as soon as I receive a response back the issue is resolved. Thanks for your patience.
  • calebkwokcalebkwok Posts: 1FreedomPop Newbie
    I am experiencing the same problem as Jeff's. I emailed my ticket to FreedomPop already and am waiting for their reply.
  • jeffv13jeffv13 Posts: 0FreedomPop Newbie
    Thanks Taylor! Still waiting patiently. :-)
  • [Deleted User][Deleted User] Posts: 31
    @jeffv13‌ - Please try a hard reset:
    To reset both the router hardware and the device software to the original factory settings:
    1. Make sure your device is powered on.
    2. Remove the back cover and locate the opening on the back of the device labeled “RESET.”
    3. Insert a paper clip into the hole and hold the button down for six seconds until the LED goes out. The LED color will vary depending on the status of the device when you reset it.
  • jeffv13jeffv13 Posts: 0FreedomPop Newbie
    Thanks Taylor! Even before doing the hard reset my device was back to normal operation yesterday when I tried. Are there any details on what the development team had to do to get my Mifi back in the system so next time I'll know what to tell the tech support guys?

    Thanks again!

    Jeff
  • [Deleted User][Deleted User] Posts: 31
    @jeffv13‌ - I don't have the details other than they fixed something internally on your account.
  • NuShrikeNuShrike Posts: 2FreedomPop Newbie
    Just got the MiFi 500 (ordered 6/18, received 6/25). Got an email about updating the PRL.

    However, EXACT same problem right out of the box.

    Phone CS is escalating it, but it's really bad when you're shipping DOA devices like this.
  • Philip WangPhilip Wang Posts: 6FreedomPop Newbie
    Interesting, my LTE hotspot stopped working a couple of weeks ago... getting the same error message. Looks like FP and Sprint have having some issues. I just put in my inquiry and hope to get a reply tomorrow. Hope the answer is not to get a replacement because I have already gotten one replacement back in January already - so this is my 2nd device.
  • shawnlgshawnlg Posts: 2FreedomPop Newbie
    It took 2 weeks to resolve my issue. Finally, the dev group said I had to be on the 3G network for it to resolve. So I had to sign up for the 3G/4G plan and then it worked. I decided to stay on that plan instead of the 4G only plan. It isn't that expensive, and it is more reliable than Sprint LTE only.
  • NuShrikeNuShrike Posts: 2FreedomPop Newbie
    Meanwhile, hard-reset the device and now it no longer activates on "Sprint". Took it to Sprint Store and called Sprint CS and they don't recognize the device at all.

    Called FPop phone support again and after fighting through CS and tech support they finally agreed to give me a device swap. Two weeks of this delay when they knew from the beginning they were shipping "miskitted" devices. CS's continued response is that I'm not in a 4G LTE area but they're willing to "upsell" me to 3G coverage.

    Of course this runs totally opposed to Taylor's response. I've submitted a detailed timeline to ****.
This discussion has been closed.