Just activated EVO 4G, and cannot receive/make calls within Wifi.

Raj ChauhanRaj Chauhan Posts: 1FreedomPop Newbie
I have just activated my EVO 4g phone, and was unable to make any phone calls using WiFi, I can receive calls via a 3G connection, but cannot make call through the 3G connection. I have tried a full phone reset as suggested by other in this forum, reloaded the FreedomPop apps, update the firmware and PRL multiple times. My MEID is A100001796130F.
Text messaging does work both ways within Wifi and 3G

Best Answer

Answers

  • Raj ChauhanRaj Chauhan Posts: 1FreedomPop Newbie
    Thanks for the suggestion, I did turn of Sprint Optimizer, but that did not fix the issue. Still no calling within Wifi, and when a call is made through non-wifi when the other end picks up the phone disconnects.
  • Raj ChauhanRaj Chauhan Posts: 1FreedomPop Newbie
    Thanks for the suggestion. I did have the Optimizer turned on, but have turned it off. Still no change in getting phone call via WiFi.
    I can do the following on my phone:
    Wifi - Place a call from another phone to this phone, the phone will ring, and be able to slide to accept the call, but does not connect to the actual call. The phone making the call is still ringing.
    Wifi- When making an outgoing call, the other phone does not ring, and this phone does not make any dialing noise.
    Non-WiFi - I can receive calls placed with the other phone.
    Non-Wifi - I can place calls, but as soon as the other phone picks-up the other phone hangs up, this happens sometimes.

    Any other suggestions ?
  • [Deleted User][Deleted User] Posts: 31
    @Raj Chauhan‌ - Please try an MSL reset (this is a RESET so please back up important info); please dial ##786#. Select the "Reset" button and then enter your MSL code: 619205

    Press the Menu button and then hit the "Reset" button and your phone will restart.

    Once the phone has restarted it may enter hands free activation. If this does not happen, then you can do so by updating your phone's PRL and Profile manually. This can be done by going to Settings > Phone/ System updates > Update PRL and then repeat for update Profile.
  • Raj ChauhanRaj Chauhan Posts: 1FreedomPop Newbie
    Taylor, I had already done an MSL reset and performed the updates to both the Profile and PRL. Both said it updated. I will attempt to do this again to see. Also should this be done on WiFi or not.
  • Raj ChauhanRaj Chauhan Posts: 1FreedomPop Newbie
    Okay so I got a chance to try again, and still no calling on WiFi, it will receive an incoming call, but I cannot pick it up and the caller continues to hear the phone ring. Tried making an outgong call and the other phone does not ring. Non wifi everything works. Any other suggestions or setting I should check/change.
  • Adolfo GalvanAdolfo Galvan Posts: 719FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FP Flyer ✭✭✭✭
    edited June 2014 #9
    Try this: Click Settings>Network and check the box that says Enable STUN. Click on STUN servers and type this: stun.l.google.com:19302 or any others on this list https://gist.github.com/zziuni/3741933 . If this works, the problem is that you are going through 2 or more NAT networks and the server is having difficultly connecting. I would NOT recommend leaving it on this setting, but to resolve the issue on your network.
  • Raj ChauhanRaj Chauhan Posts: 1FreedomPop Newbie
    Hi Adolfo, I could not find the setting>network, all I have is setting>Wireless & Network, and then within that selection there is nothing that has STUN setting in it. My Android version is 2.3.5
  • [Deleted User][Deleted User] Posts: 31
    @Raj Chauhan‌ - It seems that this may be related to issues with your router/network settings on your home WiFi. Can you please try at a public WiFi hotspot (McDonald's, Starbucks, etc.) to see if you are able to place calls over their WiFi. Thank you.
  • Ali Ali Posts: 6,735FreedomPop Master, Test Role, iOS Master ✭✭✭✭✭
    This is a WiFi issue - please restart the access point or disable port forwarding.
This discussion has been closed.