Moto G4 Play activation - no internet for over a week

stckstck Posts: 2FreedomPop Newbie
I changed from Ringplus to Freedompop on 2/4. I got an email that there are activation problems and I should wait for 24 hours, but there has been no improvement.
Support is unfortunately not replying.
Under 'devices', I only see a MAC, I do not see my device esn / iccid.
My phone does not have any internet - neither 3g nor LTE.
Any advice on fixing this issue?

Comments

  • njfulwider5njfulwider5 Posts: 10,413FreedomPop Newbie, FreedomPop Master, Test Role, FreedomPop Expert, FreedomFan, Android Master , FP Flyer ✭✭✭✭✭
    stck said:

    I changed from Ringplus to Freedompop on 2/4. I got an email that there are activation problems and I should wait for 24 hours, but there has been no improvement.
    Support is unfortunately not replying.
    Under 'devices', I only see a MAC, I do not see my device esn / iccid.
    My phone does not have any internet - neither 3g nor LTE.
    Any advice on fixing this issue?

    @stck
    Sorry for the inconvenience, I've sent you a PM in order to gather some personal information regarding your request. Please check your forum in box for the message.

    Thanks
    nj

    Great Tips and Trick, User Guides and How to's in my Signature-(Take a Peek)

    Hope you find any post I have created helpful. Please look for my How to-s(Downgrading-100% Free) and (How to use the FreedomPop Community), or my Guides on FreedomPop Devices(Phones) and (Hotspots). Here is one on (FreedomPop Plans). Here is one on all (FreedomPop Apps). He is one on(Traveling with your GSM Global Sim?) or Common Question about the (GSM Global Sim). You can PM me anytime by clicking this link here njfulwider5. Than click the BUTTON with the (Small Envelope), to left of the word (MESSAGE). I will do my best help. Welcome to FreedomPop

  • stckstck Posts: 2FreedomPop Newbie
    Thanks nj! I replied. My 3g started working after trying some of the carrier reset options mentioned on this forum, but LTE still does not work.
  • shudonghshudongh Posts: 1FreedomPop Newbie
    stck said:

    Thanks nj! I replied. My 3g started working after trying some of the carrier reset options mentioned on this forum, but LTE still does not work.

    Do you have LTE now? I have two Moto G4 Play and they're both 3g only. Additionally, I have also have an iPhone 6 connection at 3g only. I have tried resetting many times without success. All the three phone were connected at LTE when I had them with RingPlus. So it's not a hardware problem or a network problem.
  • Jean MillerJean Miller Posts: 140FreedomPop Newbie
    I'm having the same problem. Were either of you able to get this no data problem fixed?
    I like me deals and free stuff. Thx, peeps
  • ultrasoulultrasoul Posts: 17FreedomPop Newbie
    Can you share what you did? I activated a Moto G4 and had FP add the ICCID but I don't get any internet 3G or 4G. None! Updated PRL and profile doesn't help!
  • marie sonmarie son Posts: 11FreedomPop Newbie
    did you buy a right sim card ?
Sign In or Register to comment.