Galaxy Nexus S, BYOD says not supported

akajesterakajester Posts: 0FreedomPop Newbie
Hello, I'm trying to link up a phone I got here and I get the "not supported" message when I try on the website. The MEID is A000002A292A50. The model is SPH-D720. I checked the list of devices and this was listed. Do I need to call to get it connected?

Thanks!

Comments

  • [Deleted User][Deleted User] Posts: 31
    @akajester‌ - Please try activating the device again through BYOD, your device says "valid and cleared for use" on our network.
  • don juandon juan Posts: 0FreedomPop Newbie
    I have tried many times to activate the BYOD Sprint Samsung Nexus s 4g and have not being successful. The error i get is device not supported.
  • himtherehimthere Posts: 0FreedomPop Newbie
    I also have a problem activating my Samsung Nexus S - model SPH-L700 - I get a notice that the model is not currently supported, though it is on the supported list. MEID is 99000113987306. please help, thanks
  • akajesterakajester Posts: 0FreedomPop Newbie
    Thanks Taylor. I just tried it again and I get the "Snap!" response. hmm. I'll call tomorrow, maybe the third time will do it! :)
  • akajesterakajester Posts: 0FreedomPop Newbie
    Taylor I tried calling again this morning. I was told again that the device wasn't on the list of supported devices, but it checked out clean, so it's being escalated to technical support. This happened a few weeks ago too, but I never heard anything. Do you recommend that I keep waiting? My account # is 2365070. Thanks!
  • akajesterakajester Posts: 0FreedomPop Newbie
    Still nothing. I'm not sure what to do here. I have the phone but no one can get it to work. Bummer.
Sign In or Register to comment.